summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Sottile <asottile@umich.edu>2021-03-16 07:51:22 -0700
committerAnthony Sottile <asottile@umich.edu>2021-03-16 07:51:22 -0700
commit9da39388168641582ea44c177a3259a6327f8eeb (patch)
tree45b61ed7813d82e1edaf6f7422f7d2db9f90bee2
parent930e2cad15df3661306740c30a892a6f1902ef1d (diff)
downloadpep8-drop_py34.tar.gz
drop python 3.4drop_py34
github actions no longer supports python 3.4
-rw-r--r--.github/workflows/main.yml3
-rw-r--r--CONTRIBUTING.rst2
-rw-r--r--README.rst4
-rw-r--r--docs/developer.rst8
-rw-r--r--setup.py3
5 files changed, 8 insertions, 12 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 29f1bd3..4624d21 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -26,9 +26,6 @@ jobs:
py: 2.7
toxenv: py
- os: ubuntu-latest
- py: 3.4
- toxenv: py
- - os: ubuntu-latest
py: 3.5
toxenv: py
- os: ubuntu-latest
diff --git a/CONTRIBUTING.rst b/CONTRIBUTING.rst
index 4cdd213..5515108 100644
--- a/CONTRIBUTING.rst
+++ b/CONTRIBUTING.rst
@@ -55,7 +55,7 @@ Step 3: Run tests
Before creating a pull request you should run the tests to make sure that the
changes that have been made haven't caused any regressions in functionality.
-To run the tests, the core developer team and Travis-CI use `tox`_::
+To run the tests, the core developer team and GitHub Actions use `tox`_::
$ pip install -r dev-requirements.txt
$ tox
diff --git a/README.rst b/README.rst
index 7f222ce..c71b933 100644
--- a/README.rst
+++ b/README.rst
@@ -1,8 +1,8 @@
pycodestyle (formerly called pep8) - Python style guide checker
===============================================================
-.. image:: https://img.shields.io/travis/PyCQA/pycodestyle.svg
- :target: https://travis-ci.org/PyCQA/pycodestyle
+.. image:: https://github.com/PyCQA/pycodestyle/actions/workflows/main.yml/badge.svg
+ :target: https://github.com/PyCQA/pycodestyle/actions/workflows/main.yml
:alt: Build status
.. image:: https://readthedocs.org/projects/pycodestyle/badge/?version=latest
diff --git a/docs/developer.rst b/docs/developer.rst
index 080d080..74e3ede 100644
--- a/docs/developer.rst
+++ b/docs/developer.rst
@@ -13,9 +13,9 @@ conditions of the :ref:`Expat license <license>`. Fork away!
* `Source code <https://github.com/pycqa/pycodestyle>`_ and
`issue tracker <https://github.com/pycqa/pycodestyle/issues>`_ on GitHub.
-* `Continuous tests <http://travis-ci.org/pycqa/pycodestyle>`_ against Python
- 2.7 and 3.4+ as well as the nightly Python build and PyPy, on `Travis CI
- platform <https://docs.travis-ci.com//>`_.
+* `Continuous tests <https://github.com/PyCQA/pycodestyle/actions>`_ against
+ Python 2.7 and 3.5+ as well as the nightly Python build and PyPy, on GitHub
+ Actions.
.. _available on GitHub: https://github.com/pycqa/pycodestyle
@@ -103,7 +103,7 @@ Then be sure to pass the tests::
When contributing to pycodestyle, please observe our `Code of Conduct`_.
-To run the tests, the core developer team and Travis CI use tox::
+To run the tests, the core developer team and GitHub Actions use tox::
$ pip install -r dev-requirements.txt
$ tox
diff --git a/setup.py b/setup.py
index 1c117c2..148751b 100644
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ setup(
namespace_packages=[],
include_package_data=True,
zip_safe=False,
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
install_requires=[
# Broken with Python 3: https://github.com/pypa/pip/issues/650
# 'setuptools',
@@ -54,7 +54,6 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',