summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Lee <IanLee1521@gmail.com>2016-06-06 18:12:41 -0700
committerIan Lee <IanLee1521@gmail.com>2016-06-06 18:12:41 -0700
commit5e6be1d99291988e3deb8af5e6e291d3854e631b (patch)
tree1238fbaec004f1a02906a5daa0470b24c9fdccab
parent6cb59d685e635a72db2230d75b61aed99ac86b29 (diff)
downloadpep8-5e6be1d99291988e3deb8af5e6e291d3854e631b.tar.gz
Converted README to markdown
-rw-r--r--README.md78
-rw-r--r--README.rst96
-rw-r--r--setup.py2
3 files changed, 79 insertions, 97 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..9bf2335
--- /dev/null
+++ b/README.md
@@ -0,0 +1,78 @@
+pycodestyle (formerly called pep8) - Python style guide checker
+===============================================================
+
+pycodestyle is a tool to check your Python code against some of the style
+conventions in [PEP 8](http://www.python.org/dev/peps/pep-0008/).
+
+Note: This package used to be called ``pep8`` but was renamed to ``pycodestyle`` to reduce confusion. Further discussion [here](https://github.com/PyCQA/pycodestyle/issues/466).
+
+Features
+--------
+
+* Plugin architecture: Adding new checks is easy.
+
+* Parseable output: Jump to error location in your editor.
+
+* Small: Just one Python file, requires only stdlib. You can use just
+ the ``pycodestyle.py`` file for this purpose.
+
+* Comes with a comprehensive test suite.
+
+Installation
+------------
+
+You can install ``pycodestyle.py`` with ``pip``:
+
+ $ pip install pycodestyle
+
+
+Example usage and output
+------------------------
+
+ $ pycodestyle --first optparse.py
+ optparse.py:69:11: E401 multiple imports on one line
+ optparse.py:77:1: E302 expected 2 blank lines, found 1
+ optparse.py:88:5: E301 expected 1 blank line, found 0
+ optparse.py:222:34: W602 deprecated form of raising exception
+ optparse.py:347:31: E211 whitespace before '('
+ optparse.py:357:17: E201 whitespace after '{'
+ optparse.py:472:29: E221 multiple spaces before operator
+ optparse.py:544:21: W601 .has_key() is deprecated, use 'in'
+
+You can also make ``pycodestyle.py`` show the source code for each error, and
+even the relevant text from PEP 8:
+
+ $ pycodestyle --show-source --show-pep8 testsuite/E40.py
+ testsuite/E40.py:2:10: E401 multiple imports on one line
+ import os, sys
+ ^
+ Place imports on separate lines.
+
+ Okay: import os\nimport sys
+ E401: import sys, os
+
+
+Or you can display how often each error was found::
+
+ $ pycodestyle --statistics -qq Python-2.5/Lib
+ 232 E201 whitespace after '['
+ 599 E202 whitespace before ')'
+ 631 E203 whitespace before ','
+ 842 E211 whitespace before '('
+ 2531 E221 multiple spaces before operator
+ 4473 E301 expected 1 blank line, found 0
+ 4006 E302 expected 2 blank lines, found 1
+ 165 E303 too many blank lines (4)
+ 325 E401 multiple imports on one line
+ 3615 E501 line too long (82 characters)
+ 612 W601 .has_key() is deprecated, use 'in'
+ 1188 W602 deprecated form of raising exception
+
+Links
+-----
+
+[![Build Status](https://api.travis-ci.org/PyCQA/pycodestyle.png?branch=master)](https://travis-ci.org/PyCQA/pycodestyle) [![Wheel Status](https://img.shields.io/pypi/wheel/pycodestyle.svg)](https://pypi.python.org/pypi/pycodestyle)
+
+* `Read the documentation <https://pycodestyle.readthedocs.io/>`_
+
+* `Fork me on GitHub <http://github.com/PyCQA/pycodestyle>`_
diff --git a/README.rst b/README.rst
deleted file mode 100644
index 466509b..0000000
--- a/README.rst
+++ /dev/null
@@ -1,96 +0,0 @@
-pycodestyle (formerly called pep8) - Python style guide checker
-===============================================================
-
-pycodestyle is a tool to check your Python code against some of the style
-conventions in `PEP 8`_.
-
-.. _PEP 8: http://www.python.org/dev/peps/pep-0008/
-
-.. note::
-
- This package used to be called ``pep8`` but was renamed to ``pycodestyle``
- to reduce confusion. Further discussion `here
- <https://github.com/PyCQA/pycodestyle/issues/466>`_.
-
-Features
---------
-
-* Plugin architecture: Adding new checks is easy.
-
-* Parseable output: Jump to error location in your editor.
-
-* Small: Just one Python file, requires only stdlib. You can use just
- the ``pycodestyle.py`` file for this purpose.
-
-* Comes with a comprehensive test suite.
-
-Installation
-------------
-
-You can install, upgrade, uninstall ``pycodestyle.py`` with these commands::
-
- $ pip install pycodestyle
- $ pip install --upgrade pycodestyle
- $ pip uninstall pycodestyle
-
-There's also a package for Debian/Ubuntu, but it's not always the
-latest version.
-
-Example usage and output
-------------------------
-
-::
-
- $ pycodestyle --first optparse.py
- optparse.py:69:11: E401 multiple imports on one line
- optparse.py:77:1: E302 expected 2 blank lines, found 1
- optparse.py:88:5: E301 expected 1 blank line, found 0
- optparse.py:222:34: W602 deprecated form of raising exception
- optparse.py:347:31: E211 whitespace before '('
- optparse.py:357:17: E201 whitespace after '{'
- optparse.py:472:29: E221 multiple spaces before operator
- optparse.py:544:21: W601 .has_key() is deprecated, use 'in'
-
-You can also make ``pycodestyle.py`` show the source code for each error, and
-even the relevant text from PEP 8::
-
- $ pycodestyle --show-source --show-pep8 testsuite/E40.py
- testsuite/E40.py:2:10: E401 multiple imports on one line
- import os, sys
- ^
- Imports should usually be on separate lines.
-
- Okay: import os\nimport sys
- E401: import sys, os
-
-
-Or you can display how often each error was found::
-
- $ pycodestyle --statistics -qq Python-2.5/Lib
- 232 E201 whitespace after '['
- 599 E202 whitespace before ')'
- 631 E203 whitespace before ','
- 842 E211 whitespace before '('
- 2531 E221 multiple spaces before operator
- 4473 E301 expected 1 blank line, found 0
- 4006 E302 expected 2 blank lines, found 1
- 165 E303 too many blank lines (4)
- 325 E401 multiple imports on one line
- 3615 E501 line too long (82 characters)
- 612 W601 .has_key() is deprecated, use 'in'
- 1188 W602 deprecated form of raising exception
-
-Links
------
-
-.. image:: https://api.travis-ci.org/PyCQA/pycodestyle.png?branch=master
- :target: https://travis-ci.org/PyCQA/pycodestyle
- :alt: Build status
-
-.. image:: https://pypip.in/wheel/pycodestyle/badge.png?branch=master
- :target: https://pypi.python.org/pypi/pycodestyle
- :alt: Wheel Status
-
-* `Read the documentation <https://pycodestyle.readthedocs.io/>`_
-
-* `Fork me on GitHub <http://github.com/PyCQA/pycodestyle>`_
diff --git a/setup.py b/setup.py
index b77770e..8afc1b9 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,7 @@ def get_version():
def get_long_description():
descr = []
- for fname in 'README.rst', 'CHANGES.txt':
+ for fname in 'README.md', 'CHANGES.txt':
with open(fname) as f:
descr.append(f.read())
return '\n\n'.join(descr)