summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAnthony Sottile <asottile@umich.edu>2022-12-13 01:06:43 -0500
committerAnthony Sottile <asottile@umich.edu>2022-12-13 01:21:17 -0500
commite20394e5cbd8d440c9c1868ddc25d036afcbfe45 (patch)
tree0d84d5422bd5747d9f5397a7988cea24a036a058 /setup.py
parent0fd8b014cecae05ef4491254fa76fc765ec052c4 (diff)
downloadpep8-e20394e5cbd8d440c9c1868ddc25d036afcbfe45.tar.gz
drop python3.6
github actions no longer supports it
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index fe96737..2fe5a11 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ setup(
py_modules=['pycodestyle'],
include_package_data=True,
zip_safe=False,
- python_requires='>=3.6',
+ python_requires='>=3.7',
entry_points={
'console_scripts': [
'pycodestyle = pycodestyle:_main',
@@ -45,9 +45,6 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries :: Python Modules',