summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml1
-rw-r--r--CHANGES.txt2
-rw-r--r--Makefile5
-rw-r--r--setup.py1
-rw-r--r--tox.ini1
5 files changed, 9 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 1c2c279..d0a21c2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,6 +13,7 @@ script:
- python pep8.py --testsuite testsuite
- python pep8.py --statistics pep8.py
- python pep8.py --doctest
+ - python -m testsuite.test_all
matrix:
allow_failures:
- python: pypy
diff --git a/CHANGES.txt b/CHANGES.txt
index 3b1da5f..7c196e0 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -20,6 +20,8 @@ Changelog
* Do not report false E302 when the source file has a coding cookie or a
comment on the first line. (Issue #174)
+* Reorganize the tests and add basic tests for the API. (Issue #161)
+
1.4.4 (2013-02-24)
------------------
diff --git a/Makefile b/Makefile
index 26a6202..29b243d 100644
--- a/Makefile
+++ b/Makefile
@@ -7,4 +7,7 @@ selftest :
doctest :
python pep8.py --doctest
-alltest : test selftest doctest
+unittest :
+ python -m testsuite.test_all
+
+alltest : test selftest doctest unittest
diff --git a/setup.py b/setup.py
index 6f6403b..ef3f1bd 100644
--- a/setup.py
+++ b/setup.py
@@ -52,4 +52,5 @@ setup(
'Programming Language :: Python :: 3',
'Topic :: Software Development :: Libraries :: Python Modules',
],
+ test_suite='testsuite.test_all',
)
diff --git a/tox.ini b/tox.ini
index ae0797c..c743f5a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -12,6 +12,7 @@ commands =
{envpython} pep8.py --testsuite testsuite
{envpython} pep8.py --statistics pep8.py
{envpython} pep8.py --doctest
+ {envpython} pep8.py -m testsuite.test_all
[pep8]
select =