summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index fe96737..2fe5a11 100644
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ setup(
py_modules=['pycodestyle'],
include_package_data=True,
zip_safe=False,
- python_requires='>=3.6',
+ python_requires='>=3.7',
entry_points={
'console_scripts': [
'pycodestyle = pycodestyle:_main',
@@ -45,9 +45,6 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries :: Python Modules',