summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHernan Grecco <hgrecco@gmail.com>2023-05-05 03:33:45 -0300
committerHernan Grecco <hgrecco@gmail.com>2023-05-05 03:33:45 -0300
commit0b69ad47b2069e29ba48eb64b30093d53da163d6 (patch)
tree8cee3b9626615701b3dc6ae986725891c738f13f
parent2f4125d0be4caa21a4ce2726bbc266cf265d822d (diff)
downloadpint-0b69ad47b2069e29ba48eb64b30093d53da163d6.tar.gz
Add typing_extensions
Python's typing is a moving target. This allows the project to serve the users better in terms of typing support.
-rw-r--r--pyproject.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index bbcfbdf..6094bd0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -28,6 +28,9 @@ classifiers = [
]
requires-python = ">=3.9"
dynamic = ["version"] # Version is taken from git tags using setuptools_scm
+dependencies = [
+ "typing_extensions"
+]
[tool.setuptools.package-data]
pint = [