summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer McIntyre <zeroSteiner@gmail.com>2021-05-16 12:08:25 -0400
committerSpencer McIntyre <zeroSteiner@gmail.com>2021-05-16 12:08:25 -0400
commite95b6c3bd2495d0f74f9baf11eadd4f5109d4911 (patch)
tree6f19be0aea23f220313b02e393dab99a92aaad59
parentaf0454a6f0a7cdd118e63a116a2b60efc3827c32 (diff)
parent382037ce6cd81e2767143db744d1049081051ce3 (diff)
downloadpluginbase-e95b6c3bd2495d0f74f9baf11eadd4f5109d4911.tar.gz
Land #22, Update supported Python versions
-rw-r--r--.travis.yml5
-rw-r--r--setup.py4
-rw-r--r--tests/conftest.py2
-rw-r--r--tox.ini2
4 files changed, 7 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index 743a38a..739db3e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,12 @@
language: python
python:
- - "2.6"
- "2.7"
- - "3.3"
- "3.4"
- "3.5"
- "3.6"
+ - "3.7"
+ - "3.8"
+ - "3.9"
- "pypy"
install:
diff --git a/setup.py b/setup.py
index 012827f..8f9f4e6 100644
--- a/setup.py
+++ b/setup.py
@@ -29,14 +29,14 @@ setup(
classifiers=[
'License :: OSI Approved :: BSD License',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: PyPy',
'Environment :: Plugins',
'Intended Audience :: Developers',
diff --git a/tests/conftest.py b/tests/conftest.py
index a43b8cf..e20513b 100644
--- a/tests/conftest.py
+++ b/tests/conftest.py
@@ -20,7 +20,7 @@ def source(base):
identifier='demo')
-@pytest.yield_fixture(scope='function', autouse=True)
+@pytest.fixture(scope='function', autouse=True)
def run_garbage_collection():
gc.collect()
try:
diff --git a/tox.ini b/tox.ini
index dbea2bd..678eff6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py33,py34,py35,py36,pypy
+envlist = py27,py34,py35,py36,py37,py38,py39,pypy
[testenv]
commands = make test