summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Beazley <dave@dabeaz.com>2020-01-01 09:51:19 -0600
committerDavid Beazley <dave@dabeaz.com>2020-01-01 09:51:19 -0600
commit1321375e013425958ea090b55aecae0a4b7face6 (patch)
tree9569e16dde14372391142bc0d80ff0f90d72215b /Makefile
parentf6d78006324079bfe824422b9a21dc91811ecfa2 (diff)
downloadply-1321375e013425958ea090b55aecae0a4b7face6.tar.gz
initial year-end cleanup.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index b13d007..b2ac0c0 100644
--- a/Makefile
+++ b/Makefile
@@ -1,17 +1,10 @@
PYTHON ?= python
+install:
+ python install.py
+
test:
cd test && $(PYTHON) testlex.py
cd test && $(PYTHON) testyacc.py
-wheel:
- $(PYTHON) setup.py bdist_wheel
-
-sdist:
- $(PYTHON) setup.py sdist
-
-upload: wheel sdist
- $(PYTHON) setup.py bdist_wheel upload
- $(PYTHON) setup.py sdist upload
-
-.PHONY: test wheel sdist upload
+.PHONY: install test