summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2019-02-23 21:19:46 +0200
committerGitHub <noreply@github.com>2019-02-23 21:19:46 +0200
commitaa2d0bda9c4fb742eaf460f91c19125480499385 (patch)
tree0ac8740a18be8ac2ca0c6b672a12ff4eccbdfa03 /README.md
parent063eff1a7886f0bcba7648be5c2b977b1003d357 (diff)
parentdca6c606d63d4729a395f30953456b0f00d4f443 (diff)
downloadply-aa2d0bda9c4fb742eaf460f91c19125480499385.tar.gz
Merge branch 'master' into patch-1
Diffstat (limited to 'README.md')
-rw-r--r--README.md23
1 files changed, 11 insertions, 12 deletions
diff --git a/README.md b/README.md
index bef5b3b..52fa31d 100644
--- a/README.md
+++ b/README.md
@@ -1,8 +1,8 @@
-# PLY (Python Lex-Yacc) Version 3.11
+# PLY (Python Lex-Yacc)
[![Build Status](https://travis-ci.org/dabeaz/ply.svg?branch=master)](https://travis-ci.org/dabeaz/ply)
-Copyright (C) 2001-2018
+Copyright (C) 2001-2019
David M. Beazley (Dabeaz LLC)
All rights reserved.
@@ -78,19 +78,19 @@ To use PLY, simply copy the 'ply' directory to your project and import
lex and yacc from the associated 'ply' package. For example:
```python
-import ply.lex as lex
-import ply.yacc as yacc
+from .ply import lex
+from .ply import yacc
```
Alternatively, you can copy just the files lex.py and yacc.py
-individually and use them as modules. For example:
+individually and use them as modules however you see fit. For example:
```python
import lex
import yacc
```
-The file setup.py can be used to install ply using distutils.
+PLY has no third-party dependencies.
The file doc/ply.html contains complete documentation on how to use
the system.
@@ -122,7 +122,7 @@ The GitHub page for PLY can be found at:
* https://github.com/dabeaz/ply
-An old and relatively inactive discussion group for PLY is found at:
+An old and inactive discussion group for PLY is found at:
* http://groups.google.com/group/ply-hack
@@ -262,11 +262,10 @@ Bug Reports and Patches
My goal with PLY is to simply have a decent lex/yacc implementation
for Python. As a general rule, I don't spend huge amounts of time
working on it unless I receive very specific bug reports and/or
-patches to fix problems. I also try to incorporate submitted feature
-requests and enhancements into each new version. Please visit the PLY
-github page at https://github.com/dabeaz/ply to submit issues and pull
-requests. To contact me about bugs and/or new features, please send
-email to dave@dabeaz.com.
+patches to fix problems. At this time, PLY is mature software and new
+features are no longer being added. If you think you have found a
+bug, please visit the PLY Github page at https://github.com/dabeaz/ply
+to report an issue.
-- Dave