summaryrefslogtreecommitdiff
path: root/.ci
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-09-02 20:44:10 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2016-09-02 20:44:10 +0200
commit26c5ed5d205a012a88db23070d1821ad735dfbf0 (patch)
tree17186104f56cb3a8474b38a01c332c35d6a67de6 /.ci
parentb8660ede443e2018a293e49958ce9c42d9b7d08c (diff)
downloadpsutil-26c5ed5d205a012a88db23070d1821ad735dfbf0.tar.gz
try to fix 2.6 failure on travis
Diffstat (limited to '.ci')
-rwxr-xr-x.ci/travis/run.sh14
1 files changed, 12 insertions, 2 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index 4269f30c..e70b58b8 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -3,6 +3,9 @@
set -e
set -x
+PYVER=`python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))'`
+
+# setup OSX
if [[ "$(uname -s)" == 'Darwin' ]]; then
if which pyenv > /dev/null; then
eval "$(pyenv init -)"
@@ -10,15 +13,22 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv activate psutil
fi
+# install psutil
python setup.py build
python setup.py develop
+# run tests (with coverage)
if [[ "$(uname -s)" != 'Darwin' ]]; then
coverage run psutil/tests/runner.py --include="psutil/*" --omit="test/*,*setup*"
else
python psutil/tests/runner.py
fi
+# run mem leaks test
python psutil/tests/test_memory_leaks.py
-flake8
-pep8
+
+# run linters
+if [ "$PYVER" != "2.6" ]; then
+ flake8
+ pep8
+fi