summaryrefslogtreecommitdiff
path: root/.ci
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-02-08 08:59:16 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-02-08 08:59:16 +0100
commitd1cf8cf1655ade8649e56bfdbf18712974285ada (patch)
tree9c64bee60e5f289640b864b5084a4e16bbcb9005 /.ci
parent5bb315297d3e1cbc12d0532c74b792820363cd39 (diff)
downloadpsutil-d1cf8cf1655ade8649e56bfdbf18712974285ada.tar.gz
try to fix ci tests
Diffstat (limited to '.ci')
-rwxr-xr-x.ci/travis/install.sh14
-rwxr-xr-x.ci/travis/run.sh2
2 files changed, 8 insertions, 8 deletions
diff --git a/.ci/travis/install.sh b/.ci/travis/install.sh
index 23d9ce04..c6774797 100755
--- a/.ci/travis/install.sh
+++ b/.ci/travis/install.sh
@@ -16,11 +16,11 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
py26)
pyenv install 2.6.9
pyenv virtualenv 2.6.9 psutil
- ;;
+ ;;
py27)
pyenv install 2.7.10
pyenv virtualenv 2.7.10 psutil
- ;;
+ ;;
py32)
pyenv install 3.2.6
pyenv virtualenv 3.2.6 psutil
@@ -38,14 +38,14 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
pyenv activate psutil
fi
-if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]] || [[ $PYVER == 'py26' ]]; then
+if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]] || [[ $PYVER == 'py26' ]]; then
pip install -U ipaddress unittest2 mock==1.0.1
-elif [[ $TRAVIS_PYTHON_VERSION == '2.7' ]] || [[ $PYVER == 'py27' ]]; then
+elif [[ $TRAVIS_PYTHON_VERSION == '2.7' ]] || [[ $PYVER == 'py27' ]]; then
pip install -U ipaddress mock
-elif [[ $TRAVIS_PYTHON_VERSION == '3.2' ]] || [[ $PYVER == 'py32' ]]; then
+elif [[ $TRAVIS_PYTHON_VERSION == '3.2' ]] || [[ $PYVER == 'py32' ]]; then
pip install -U ipaddress mock
-elif [[ $TRAVIS_PYTHON_VERSION == '3.3' ]] || [[ $PYVER == 'py33' ]]; then
+elif [[ $TRAVIS_PYTHON_VERSION == '3.3' ]] || [[ $PYVER == 'py33' ]]; then
pip install -U ipaddress
fi
-pip install coverage coveralls flake8 pep8 \ No newline at end of file
+pip install coverage coveralls flake8 pep8 setuptools
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index ce21e8ac..9bb62cbf 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -11,7 +11,7 @@ if [[ "$(uname -s)" == 'Darwin' ]]; then
fi
python setup.py build
-python setup.py install
+python setup.py develop
coverage run psutil/tests/runner.py --include="psutil/*" --omit="test/*,*setup*"
python psutil/tests/test_memory_leaks.py
flake8