summaryrefslogtreecommitdiff
path: root/.flake8
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-05-25 15:26:09 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-05-25 15:26:09 +0200
commit54c0648bd1d7552d27c577d65f70c25023001071 (patch)
tree44e37c99e6978e97b36be577a40dac3d463dad2a /.flake8
parent379598312f60bf414afa8bf549f7f26af9e578ea (diff)
downloadpsutil-54c0648bd1d7552d27c577d65f70c25023001071.tar.gz
integrate flake8-blind-except plugin
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to '.flake8')
-rw-r--r--.flake827
1 files changed, 16 insertions, 11 deletions
diff --git a/.flake8 b/.flake8
index 20025785..c9a9cbb6 100644
--- a/.flake8
+++ b/.flake8
@@ -3,15 +3,20 @@
[flake8]
ignore =
- W504 # line break after binary operator
- # --- flake8-bugbear
- B007 # Loop control variable 'keyword' not used within the loop body. If this is intended, start the name with an underscore.
- B014 # Redundant exception types in `except (IOError, OSError) as err:`. Write `except OSError as err:`, which catches exactly the same exceptions.
- B008 # Do not perform function calls in argument defaults.
+ W504 # line break after binary operator
+
+ # --- flake8-bugbear plugin
+ B007 # Loop control variable 'keyword' not used within the loop body. If this is intended, start the name with an underscore.
+ B014 # Redundant exception types in `except (IOError, OSError) as err:`. Write `except OSError as err:`, which catches exactly the same exceptions.
+ B008 # Do not perform function calls in argument defaults.
+
+ # --- flake8-blind-except plugin
+ B902 # blind except Exception: statement
+
per-file-ignores =
- # T001 = print() statement
- setup.py:T001
- scripts/*:T001
- psutil/tests/runner.py:T001
- psutil/tests/test_memleaks.py:T001
- .github/workflows/*:T001
+ # T001, T201 = print() statement (flake8-print plugin)
+ setup.py:T001,T201
+ scripts/*:T001,T201
+ psutil/tests/runner.py:T001,T201
+ psutil/tests/test_memleaks.py:T001,T201
+ .github/workflows/*:T001,T201