summaryrefslogtreecommitdiff
path: root/.flake8
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-06-08 00:42:49 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-06-08 00:42:49 +0200
commit8151bbe1ec2057a9c44eaefdd23e4f59788147b0 (patch)
tree704d9db1cb4a0d9fd6dc5cc9cef2ae006a3fcde6 /.flake8
parentddea4072684561fc8fe754a7f2baf0cc6a787c33 (diff)
downloadpsutil-8151bbe1ec2057a9c44eaefdd23e4f59788147b0.tar.gz
update flake8-ers
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to '.flake8')
-rw-r--r--.flake833
1 files changed, 18 insertions, 15 deletions
diff --git a/.flake8 b/.flake8
index 29fdec97..8be0bfcf 100644
--- a/.flake8
+++ b/.flake8
@@ -3,23 +3,26 @@
[flake8]
ignore =
- W504 # line break after binary operator
+ W504 # line break after binary operator
- # --- flake8-bugbear plugin
- B007 # Loop control variable 'keyword' not used within the loop body. If this is intended, start the name with an underscore.
- B014 # Redundant exception types in `except (IOError, OSError) as err:`. Write `except OSError as err:`, which catches exactly the same exceptions.
- B008 # Do not perform function calls in argument defaults.
+ # --- flake8-bugbear plugin
+ B007 # Loop control variable 'keyword' not used within the loop body. If this is intended, start the name with an underscore.
+ B014 # Redundant exception types in `except (IOError, OSError) as err:`. Write `except OSError as err:`, which catches exactly the same exceptions.
+ B008 # Do not perform function calls in argument defaults.
- # --- flake8-blind-except plugin
- B902 # blind except Exception: statement
+ # --- flake8-blind-except plugin
+ B902 # blind except Exception: statement
- # --- flake8-quotes plugin
- Q000 # Double quotes found but single quotes preferred
+ # --- flake8-quotes plugin
+ Q000 # Double quotes found but single quotes preferred
+
+ # --- flake8-quotes naming; disable all except N804 and N805
+ N801, N802, N803, N806, N807, N811, N812, N813, N814, N815, N816, N817, N818
per-file-ignores =
- # T001, T201 = print() statement (flake8-print plugin)
- setup.py:T001,T201
- scripts/*:T001,T201
- psutil/tests/runner.py:T001,T201
- psutil/tests/test_memleaks.py:T001,T201
- .github/workflows/*:T001,T201
+ # T001, T201 = print() statement (flake8-print plugin)
+ setup.py:T001,T201
+ scripts/*:T001,T201
+ psutil/tests/runner.py:T001,T201
+ psutil/tests/test_memleaks.py:T001,T201
+ .github/workflows/*:T001,T201