summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-10-05 14:16:05 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2016-10-05 14:16:05 +0200
commit47b68916eb3678ab81ddee4e3643ff4dcf8b66c9 (patch)
tree9302aaceaa65902e0ad2eb508b43efd545e3c544
parent0e990877cedad07a80904f674ae031daf812494c (diff)
downloadpsutil-release-4.4.2.tar.gz
fix #931: compilation error on solarisrelease-4.4.2
-rw-r--r--HISTORY.rst11
-rw-r--r--appveyor.yml1
-rw-r--r--docs/index.rst3
-rw-r--r--psutil/__init__.py2
-rw-r--r--psutil/_psutil_posix.c1
5 files changed, 16 insertions, 2 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 428b9074..fb8505be 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -1,5 +1,16 @@
*Bug tracker at https://github.com/giampaolo/psutil/issues*
+4.4.2
+=====
+
+*2016-10-26*
+
+Bug fixes
+---------
+
+- 931_: psutil no longer compiles on Solaris.
+
+
4.4.1
=====
diff --git a/appveyor.yml b/appveyor.yml
index 801df0f3..927d9cb3 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -113,3 +113,4 @@ only_commits:
psutil/tests/test_windows.py
scripts/*
setup.py
+
diff --git a/docs/index.rst b/docs/index.rst
index 5a0a6139..521b95f2 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -1829,7 +1829,8 @@ take a look at the
Timeline
========
-- 2016-10-23: `psutil-4.4.1.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.4.1&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#441>`__
+- 2016-10-26: `psutil-4.4.2.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.4.2&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#442>`__
+- 2016-10-25: `psutil-4.4.1.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.4.1&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#441>`__
- 2016-10-23: `psutil-4.4.0.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.4.0&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#440>`__
- 2016-09-01: `psutil-4.3.1.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.3.1&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#431>`__
- 2016-06-18: `psutil-4.3.0.tar.gz <https://pypi.python.org/pypi?name=psutil&version=4.3.0&:action=files>`__ - `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#430>`__
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 12dffaaf..156b037f 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -187,7 +187,7 @@ __all__ = [
]
__all__.extend(_psplatform.__extra__all__)
__author__ = "Giampaolo Rodola'"
-__version__ = "4.4.1"
+__version__ = "4.4.2"
version_info = tuple([int(num) for num in __version__.split('.')])
AF_LINK = _psplatform.AF_LINK
_TOTAL_PHYMEM = None
diff --git a/psutil/_psutil_posix.c b/psutil/_psutil_posix.c
index afe4fdac..698b4b1a 100644
--- a/psutil/_psutil_posix.c
+++ b/psutil/_psutil_posix.c
@@ -34,6 +34,7 @@
#if defined(__sun)
#include <netdb.h>
+#include <sys/sockio.h>
#endif