summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2019-11-06 16:53:02 +0800
committerGiampaolo Rodola <g.rodola@gmail.com>2019-11-06 16:53:02 +0800
commit35400e8f17087a69fc7ce672f6eb172698b04f88 (patch)
treeda3958c5f4b40eb5f7b7c12a46266d3bf47788f0
parent70abf32eb3c803a0a527c3784c3baca3ae041bcb (diff)
downloadpsutil-35400e8f17087a69fc7ce672f6eb172698b04f88.tar.gz
#1615, 1614: remove pyproject.toml
-rw-r--r--HISTORY.rst9
-rw-r--r--docs/index.rst4
-rw-r--r--psutil/__init__.py2
-rw-r--r--pyproject.toml6
4 files changed, 14 insertions, 7 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 04157cbf..698db920 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -1,5 +1,14 @@
*Bug tracker at https://github.com/giampaolo/psutil/issues*
+5.6.5
+=====
+
+2019-11-06
+
+**Bug fixes**
+
+- 1615_: remove pyproject.toml as it was causing installation issues.
+
5.6.4
=====
diff --git a/docs/index.rst b/docs/index.rst
index e86fd419..74a4c36e 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -2635,6 +2635,10 @@ take a look at the `development guide`_.
Timeline
========
+- 2019-11-06:
+ `5.6.5 <https://pypi.org/project/psutil/5.6.5/#files>`__ -
+ `what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#565>`__ -
+ `diff <https://github.com/giampaolo/psutil/compare/release-5.6.4...release-5.6.5#files_bucket>`__
- 2019-11-04:
`5.6.4 <https://pypi.org/project/psutil/5.6.4/#files>`__ -
`what's new <https://github.com/giampaolo/psutil/blob/master/HISTORY.rst#564>`__ -
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 62dadc90..3f380589 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -222,7 +222,7 @@ __all__ = [
__all__.extend(_psplatform.__extra__all__)
__author__ = "Giampaolo Rodola'"
-__version__ = "5.6.4"
+__version__ = "5.6.5"
version_info = tuple([int(num) for num in __version__.split('.')])
_timer = getattr(time, 'monotonic', time.time)
diff --git a/pyproject.toml b/pyproject.toml
deleted file mode 100644
index 7f59610c..00000000
--- a/pyproject.toml
+++ /dev/null
@@ -1,6 +0,0 @@
-[build-system]
-requires = [
- "setuptools >= 41.0.0",
- "wheel >= 0.29.0",
-]
-build-backend = 'setuptools.build_meta'