summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-09-26 06:14:50 -0700
committerGiampaolo Rodola <g.rodola@gmail.com>2018-09-26 15:14:50 +0200
commit7be5d9c6a1d829c60855edec6543039db6316631 (patch)
treea0b45259758e1f822a4045e5b5dae506246e5b5d
parentab9a381f5cd9b33b244a4883d6ba55208c049dcf (diff)
downloadpsutil-7be5d9c6a1d829c60855edec6543039db6316631.tar.gz
Correct capitalization of PyPI (#1337)
As spelled on https://pypi.org/.
-rw-r--r--HISTORY.rst4
-rw-r--r--INSTALL.rst2
-rw-r--r--Makefile4
-rw-r--r--docs/index.rst2
-rw-r--r--make.bat2
-rwxr-xr-xscripts/internal/winmake.py2
6 files changed, 8 insertions, 8 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 1cd61ed8..0b6f3852 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -213,7 +213,7 @@ XXXX-XX-XX
**Compatibility notes**
-- 1120_: .exe files for Windows are no longer uploaded on PYPI as per PEP-527;
+- 1120_: .exe files for Windows are no longer uploaded on PyPI as per PEP-527;
only wheels are provided.
5.3.0
@@ -1227,7 +1227,7 @@ DeprecationWarning.
**Enhancements**
-- 410_: host tar.gz and windows binary files are on PYPI.
+- 410_: host tar.gz and windows binary files are on PyPI.
- 412_: [Linux] get/set process resource limits.
- 415_: [Windows] Process.get_children() is an order of magnitude faster.
- 426_: [Windows] Process.name is an order of magnitude faster.
diff --git a/INSTALL.rst b/INSTALL.rst
index 6644fb37..aaa1b87f 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -76,7 +76,7 @@ Windows
The easiest way to install psutil on Windows is to just use the pre-compiled
exe/wheel installers hosted on
-`PYPI <https://pypi.org/project/psutil/#files>`__ via pip:
+`PyPI <https://pypi.org/project/psutil/#files>`__ via pip:
.. code-block:: bat
diff --git a/Makefile b/Makefile
index 51047383..25928e0a 100644
--- a/Makefile
+++ b/Makefile
@@ -210,7 +210,7 @@ upload-src: ## Upload source tarball on https://pypi.org/project/psutil/
${MAKE} sdist
$(PYTHON) setup.py sdist upload
-upload-win-wheels: ## Upload wheels in dist/* directory on PYPI.
+upload-win-wheels: ## Upload wheels in dist/* directory on PyPI.
$(PYTHON) -m twine upload dist/*.whl
# --- others
@@ -233,7 +233,7 @@ pre-release: ## Check if we're ready to produce a new release.
release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
${MAKE} pre-release
- $(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PYPI
+ $(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PyPI
${MAKE} git-tag-release
print-announce: ## Print announce of new release.
diff --git a/docs/index.rst b/docs/index.rst
index a3fca7b5..7763b6de 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -53,7 +53,7 @@ The easiest way to install psutil is via ``pip``::
On UNIX this requires a C compiler (e.g. gcc) installed. On Windows pip will
automatically retrieve a pre-compiled wheel version from
-`PYPI repository <https://pypi.org/project/psutil>`__.
+`PyPI repository <https://pypi.org/project/psutil>`__.
Alternatively, see more detailed
`install <https://github.com/giampaolo/psutil/blob/master/INSTALL.rst>`_
instructions.
diff --git a/make.bat b/make.bat
index c7c31902..43000535 100644
--- a/make.bat
+++ b/make.bat
@@ -26,7 +26,7 @@ if "%TSCRIPT%" == "" (
set TSCRIPT=psutil\tests\__main__.py
)
-rem Needed to locate the .pypirc file and upload exes on PYPI.
+rem Needed to locate the .pypirc file and upload exes on PyPI.
set HOME=%USERPROFILE%
%PYTHON% scripts\internal\winmake.py %1 %2 %3 %4 %5 %6
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index ffdfc291..c4722a02 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -229,7 +229,7 @@ def wheel():
@cmd
def upload_wheels():
- """Upload wheel files on PYPI."""
+ """Upload wheel files on PyPI."""
build()
sh("%s -m twine upload dist/*.whl" % PYTHON)