summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-09-08 12:47:16 +0800
committerGiampaolo Rodola <g.rodola@gmail.com>2017-09-08 12:47:23 +0800
commitde5f2f80fe54194663eef3c9cdd709efd91576ec (patch)
treecab2be40f72c1d2d515058b8048d795f59cd5d80
parente950259b745317ceac9870d2acfcbfc7a946cbcb (diff)
downloadpsutil-de5f2f80fe54194663eef3c9cdd709efd91576ec.tar.gz
re: #1120 / PEP527: no longer provide .exe files for Windows
-rw-r--r--HISTORY.rst5
-rw-r--r--appveyor.yml1
-rwxr-xr-xscripts/internal/download_exes.py4
-rwxr-xr-xscripts/internal/winmake.py7
4 files changed, 7 insertions, 10 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 7fe75490..6379930e 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -9,6 +9,11 @@ XXXX-XX-XX
- 1124_: documentation moved to http://psutil.readthedocs.io
+**Compatibility notes**
+
+- 1120_: .exe files for Windows are no longer uploaded on PYPI as per PEP-527;
+ only wheels are provided.
+
*2017-09-01*
5.3.0
diff --git a/appveyor.yml b/appveyor.yml
index d4671784..b1867724 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -95,7 +95,6 @@ test_script:
after_test:
- "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
- - "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wininst"
artifacts:
- path: dist\*
diff --git a/scripts/internal/download_exes.py b/scripts/internal/download_exes.py
index 9688919b..5c2d70ac 100755
--- a/scripts/internal/download_exes.py
+++ b/scripts/internal/download_exes.py
@@ -170,8 +170,8 @@ def main(options):
completed += 1
print("downloaded %-45s %s" % (
local_fname, bytes2human(os.path.getsize(local_fname))))
- # 2 exes (32 and 64 bit) and 2 wheels (32 and 64 bit) for each ver.
- expected = len(PY_VERSIONS) * 4
+ # 2 wheels (32 and 64 bit) per supported python version
+ expected = len(PY_VERSIONS) * 2
if expected != completed:
return exit("expected %s files, got %s" % (expected, completed))
if exc:
diff --git a/scripts/internal/winmake.py b/scripts/internal/winmake.py
index 138a0b0c..c2ee2ab0 100755
--- a/scripts/internal/winmake.py
+++ b/scripts/internal/winmake.py
@@ -205,13 +205,6 @@ def build():
@cmd
-def build_exe():
- """Create exe file."""
- build()
- sh("%s setup.py bdist_wininst" % PYTHON)
-
-
-@cmd
def build_wheel():
"""Create wheel file."""
build()