summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-07-11 15:35:51 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2015-07-11 15:35:51 +0200
commitdf7d84079a3e30defc96bf6fb14e2784f8a587ea (patch)
tree6b23dc8688b4f41f276702c8d1cf5b9625b6a6f0
parent7f43bf5c2731d8331c19469251fa128abc52c22a (diff)
downloadpsutil-df7d84079a3e30defc96bf6fb14e2784f8a587ea.tar.gz
appveyor experiment
-rw-r--r--.appveyor/README2
-rw-r--r--appveyor.yml7
-rw-r--r--make.bat2
-rw-r--r--test/test_psutil.py19
4 files changed, 22 insertions, 8 deletions
diff --git a/.appveyor/README b/.appveyor/README
new file mode 100644
index 00000000..2e092a07
--- /dev/null
+++ b/.appveyor/README
@@ -0,0 +1,2 @@
+This directory contains support files for appveyor, a continuous integration
+service which runs tests on Windows on every push.
diff --git a/appveyor.yml b/appveyor.yml
index f3bbfb30..b23d2c1a 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -55,7 +55,7 @@ install:
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build build_ext -i"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py install"
- - "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe install unittest2 ipaddress wmi wheel --upgrade"
+ - "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe install unittest2 ipaddress pypiwin32 wmi wheel --upgrade"
# 1.0.1 is the latest release supporting python 2.6
- "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe install mock==1.0.1"
@@ -64,12 +64,11 @@ build: off
test_script:
- "%WITH_COMPILER% %PYTHON%/python test/test_psutil.py"
-
after_test:
- "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
artifacts:
- path: dist\*
-#on_success:
-# - TODO: upload the content of dist/*.whl to a public wheelhouse
+# on_success:
+# - might want to upload the content of dist/*.whl to a public wheelhouse
diff --git a/make.bat b/make.bat
index f860cdfb..c6e0dd05 100644
--- a/make.bat
+++ b/make.bat
@@ -178,7 +178,7 @@ if "%1" == "setup-env" (
@echo installing deps for %%P
@echo ------------------------------------------------
rem mandatory / for unittests
- %%P -m pip install unittest2 ipaddress mock wmi wheel --upgrade
+ %%P -m pip install unittest2 ipaddress mock wmi wheel pypiwin32 --upgrade
rem nice to have
%%P -m pip install ipdb pep8 pyflakes flake8 --upgrade
)
diff --git a/test/test_psutil.py b/test/test_psutil.py
index ff582cf7..fa2e14ce 100644
--- a/test/test_psutil.py
+++ b/test/test_psutil.py
@@ -103,6 +103,9 @@ VALID_PROC_STATUSES = [getattr(psutil, x) for x in dir(psutil)
if x.startswith('STATUS_')]
# whether we're running this test suite on Travis (https://travis-ci.org/)
TRAVIS = bool(os.environ.get('TRAVIS'))
+# whether we're running this test suite on Appveyor for Windows
+# (http://www.appveyor.com/)
+APPVEYOR = bool(os.environ.get('APPVEYOR'))
if TRAVIS or 'tox' in sys.argv[0]:
import ipaddress
@@ -1054,6 +1057,8 @@ class TestSystemAPIs(unittest.TestCase):
@unittest.skipIf(LINUX and not os.path.exists('/proc/diskstats'),
'/proc/diskstats not available on this linux version')
+ @unittest.skipIf(APPVEYOR,
+ "can't find any physical disk on Appveyor")
def test_disk_io_counters(self):
def check_ntuple(nt):
self.assertEqual(nt[0], nt.read_count)
@@ -1086,7 +1091,8 @@ class TestSystemAPIs(unittest.TestCase):
def test_users(self):
users = psutil.users()
- self.assertNotEqual(users, [])
+ if not APPVEYOR:
+ self.assertNotEqual(users, [])
for user in users:
assert user.name, user
user.terminal
@@ -1745,6 +1751,8 @@ class TestProcess(unittest.TestCase):
# TODO
@unittest.skipIf(BSD, "broken on BSD, see #595")
+ @unittest.skipIf(APPVEYOR,
+ "can't find any process file on Appveyor")
def test_open_files(self):
# current process
p = psutil.Process()
@@ -1775,6 +1783,8 @@ class TestProcess(unittest.TestCase):
# TODO
@unittest.skipIf(BSD, "broken on BSD, see #595")
+ @unittest.skipIf(APPVEYOR,
+ "can't find any process file on Appveyor")
def test_open_files2(self):
# test fd and path fields
with open(TESTFN, 'w') as fileobj:
@@ -2615,7 +2625,8 @@ class TestMisc(unittest.TestCase):
r = func(p)
self.assertIn("psutil.Process", r)
self.assertIn("pid=%s" % p.pid, r)
- self.assertIn("name='%s'" % p.name(), r)
+ self.assertIn("name=", r)
+ self.assertIn(p.name(), r)
with mock.patch.object(psutil.Process, "name",
side_effect=psutil.ZombieProcess(os.getpid())):
p = psutil.Process()
@@ -2787,7 +2798,8 @@ class TestMisc(unittest.TestCase):
if LINUX and not os.path.exists('/proc/diskstats'):
pass
else:
- check(psutil.disk_io_counters())
+ if not APPVEYOR:
+ check(psutil.disk_io_counters())
check(psutil.disk_partitions())
check(psutil.disk_usage(os.getcwd()))
check(psutil.users())
@@ -2865,6 +2877,7 @@ class TestExampleScripts(unittest.TestCase):
def test_process_detail(self):
self.assert_stdout('process_detail.py')
+ @unittest.skipIf(APPVEYOR, "can't find users on Appveyor")
def test_who(self):
self.assert_stdout('who.py')