summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-03-05 22:33:17 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-03-05 22:33:17 +0100
commit35bc2fe32093b19ae91d9e765d222da2b638855c (patch)
tree3b3c6bd435f4d98e7d24aeebec102217810526b0 /INSTALL.rst
parent663d7a6cc8867b5401027b172be2cfa43627c425 (diff)
downloadpsutil-35bc2fe32093b19ae91d9e765d222da2b638855c.tar.gz
update INSTALL
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst139
1 files changed, 59 insertions, 80 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index a38980fc..49414a2e 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -1,110 +1,88 @@
-============================
-Installing using pip on UNIX
-============================
+.. note::
+ pip is the easiest way to install psutil.
+ It is shipped by default with Python 2.7.9+ and 3.4+. If you're using
+ an older Python version
+ `install pip <https://pip.pypa.io/en/latest/installing/>`__ first.
-The easiest way to install psutil on UNIX is by using pip (but first you might
-need to install python header files; see later).
-First install pip::
+=====
+Linux
+=====
- $ wget https://bootstrap.pypa.io/get-pip.py
- $ python get-pip.py
+Ubuntu::
-...then run::
+ sudo apt-get install gcc python-dev
+ pip install psutil
- $ pip install psutil
+RedHat::
-You may need to install gcc and python header files first (see later).
+ sudo yum install gcc python-devel
+ pip install psutil
+OSX
+===
-=====================
-Installing on Windows
-=====================
+Install `XcodeTools <https://developer.apple.com/downloads/?name=Xcode>`__
+first, then:
-Just get the right installer for your Python version and architecture from:
-https://pypi.python.org/pypi/psutil/#downloads
-Since wheels installers are also available you may also use pip.
+::
+ pip install psutil
-========================================
-Compiling on Windows using Visual Studio
-========================================
+Windows
+=======
-In order to compile psutil on Windows you'll need **Visual Studio** (**Mingw32
-is no longer supported**). Depending on the Python version you'll also need a
-specific VS version.
-The links reported down here used to work at the time this was written
-(Sep 2015):
+The easiest way to install psutil on Windows is to just use the pre-compiled
+exe/wheel installers on
+`PYPI <https://pypi.python.org/pypi/psutil/#downloads>`__ via pip::
-* Python 2.6: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`__).
-* Python 2.7: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`__).
-* Python 3.3: VS 2010 (download it from `here <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__).
-* Python 3.4: VS 2010 (download it from `here <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__).
-* Python 3.5+: VS 2015 (download it from `here <http://www.visualstudio.com/en-au/news/vs2015-preview-vs>`__).
+ C:\Python27\python.exe -m pip install psutil
-To build:
+If you want to compile psutil from sources you'll need **Visual Studio**
+(Mingw32 is no longer supported):
- setup.py build
-
-To install:
-
- setup.py install
+* Python 2.6, 2.7: `VS-2008 <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`__
+* Python 3.3, 3.4: `VS-2010 <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__
+* Python 3.5+: `VS-2015 <http://www.visualstudio.com/en-au/news/vs2015-preview-vs>`__
Compiling 64 bit versions of Python 2.6 and 2.7 with VS 2008 requires
-Windows SDK and .NET Framework 3.5 SP1 to be installed first.
-Once you have those run vcvars64.bat, then compile (see
+`Windows SDK and .NET Framework 3.5 SP1 <https://www.microsoft.com/en-us/download/details.aspx?id=3138>`__.
+Once installed run vcvars64.bat, then you can finally compile (see
`here <http://stackoverflow.com/questions/11072521/>`__).
+To compile / install psutil from sources on Windows run::
-===================
-Installing on Linux
-===================
-
-gcc is required and so the python headers. They can easily be installed by
-using the distro package manager. For example, on Debian and Ubuntu::
-
- $ sudo apt-get install gcc python-dev
-
-...on Redhat and CentOS::
-
- $ sudo yum install gcc python-devel
-
-Once done, you can build/install psutil with::
-
- $ python setup.py install
-
-
-=================
-Installing on OSX
-=================
-
-OSX installation from source will require gcc which you can obtain as part of
-the `XcodeTools <https://developer.apple.com/downloads/?name=Xcode>`__
-installer from Apple.
-Once you have installed XCode you can run the standard distutils commands.
-To build only::
-
- $ python setup.py build
+ make.bat build
+ make.bat install
-To install and build::
+FreeBSD
+=======
- $ python setup.py install
+XXX
+OpenBSD
+=======
-=====================
-Installing on FreeBSD
-=====================
+Note - tested on OpenBSD 5.8::
-The same compiler used to install Python must be present on the system in order
-to build modules using distutils. Assuming it is installed, you can build using
-the standard distutils commands.
+ PKG_PATH=http://mirrors.nycbug.org/pub/OpenBSD/5.8/packages/i386/
+ export PKG_PATH
+ pkg_add -v python
+ python -m pip install psutil
-Build only::
+NetBSD
+======
- $ python setup.py build
+Note - tested on NetBSD 7.0::
-Install and build::
+ PKG_PATH="http://ftp.netbsd.org/pub/pkgsrc/packages/NetBSD/i386/7.0/All"
+ export PKG_PATH
+ pkg_add -v pkgin
+ pkgin install python
+ python -m pip install psutil
- $ python setup.py install
+Solaris
+=======
+XXX
========
Makefile
@@ -112,7 +90,8 @@ Makefile
A makefile is available for both UNIX and Windows (make.bat). It provides
some automations for the tasks described above and might be preferred over
-using setup.py. Some useful commands:
+using setup.py. It is useful only if you want to develop for psutil.
+Some useful commands::
$ make install # just install (in --user mode)
$ make uninstall # uninstall (needs pip)