summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-02-13 21:56:10 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2015-02-13 21:56:10 +0100
commit3eeb4b9b896e93e03742d3ed4a6909b9f7d4e077 (patch)
tree4c0ede83646644f80f576558448d4b7edfe14ce1 /INSTALL.rst
parent98f43e93ae1dc1f85de2a2458b11a22aaaf8a90a (diff)
downloadpsutil-3eeb4b9b896e93e03742d3ed4a6909b9f7d4e077.tar.gz
update INSTALL
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst44
1 files changed, 9 insertions, 35 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 72072065..84dded40 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -6,8 +6,8 @@ The easiest way to install psutil on UNIX is by using pip (but first you might
need to install python header files; see later).
First install pip::
- $ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
- python ez_setup.py
+ $ wget https://bootstrap.pypa.io/get-pip.py
+ $ python get-pip.py
...then run::
@@ -22,43 +22,21 @@ Installing on Windows
Just get the right installer for your Python version and architecture from:
https://pypi.python.org/pypi/psutil/#downloads
-
-
-==================================
-Compiling on Windows using mingw32
-==================================
-
-First install mingw (http://www.mingw.org/) then add mingw "bin" folder to
-environment PATH (NOTE: this assumes MinGW is installed in C:\MinGW)::
-
- SET PATH=C:\MinGW\bin;%PATH%
-
-You can then compile psutil by running::
-
- setup.py build -c mingw32
-
-To compile and install::
-
- setup.py build -c mingw32 install
-
-You can also use make.bat which automatically sets the env variable for you::
-
- make.bat build
-
-FWIW I managed to compile psutil against all 32-bit Python versions but not
-64 bit.
+Since wheels installers are also available you may also use pip.
========================================
Compiling on Windows using Visual Studio
========================================
-To use Visual Studio to compile psutil you must have the same version of
-Visual Studio used to compile your installation of Python which is::
+In order to compile psutil on Windows you'll need Visual Studio (Mingw32 is
+no longer supported). You must have the same version of Visual Studio used to compile
+your installation of Python, that is::
Python 2.6: VS 2008
Python 2.7: VS 2008
- Python 3.3+: VS 2010
+ Python 3.3, 3.4: VS 2010 (you can download it form `MS website <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__)
+ Python 3.5: `VS 2015 UP <http://www.visualstudio.com/en-au/news/vs2015-preview-vs>`__
...then run::
@@ -73,10 +51,6 @@ Windows SDK and .NET Framework 3.5 SP1 to be installed first.
Once you have those run vcvars64.bat, then compile:
http://stackoverflow.com/questions/11072521/
-If you do not have the right version of Visual Studio available then try using
-MinGW instead.
-
-
===================
Installing on Linux
===================
@@ -136,7 +110,7 @@ A makefile is available for both UNIX and Windows (make.bat). It provides
some automations for the tasks described above and might be preferred over
using setup.py. With it you can::
- $ make install # just install
+ $ make install # just install (in --user mode)
$ make uninstall # uninstall (needs pip)
$ make test # run tests
$ make clean # remove installation files