summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2019-03-05 12:36:11 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2019-03-05 12:36:11 +0100
commit5357f94010f49bed052046ff07bb534d569bff64 (patch)
treed760880e1a78de26358131c63ce4e45772b2a176 /INSTALL.rst
parent95244de84f59f4793bc806196b383fbd217aa639 (diff)
downloadpsutil-5357f94010f49bed052046ff07bb534d569bff64.tar.gz
pre-release
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst54
1 files changed, 25 insertions, 29 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 567758c9..68c63917 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -20,43 +20,43 @@ Permission issues (UNIX)
========================
The commands below assume you're running as root.
-If you're not or you bump into permission errors you can either install psutil
+If you aren't or you bump into permission errors you can either install psutil
for your user only::
- pip install --user psutil
+ pip3 install --user psutil
-...or prepend ``sudo``, e.g.::
+...or prepend ``sudo`` and install it globally, e.g.::
- sudo pip install psutil
+ sudo pip3 install psutil
Linux
=====
Ubuntu / Debian::
- sudo apt-get install gcc python-dev python-pip
- pip install psutil
+ sudo apt-get install gcc python3-dev
+ pip3 install psutil
RedHat / CentOS::
- sudo yum install gcc python-devel python-pip
- pip install psutil
+ sudo yum install gcc python3-devel
+ pip3 install psutil
-If you're on Python 3 use ``python3-dev`` and ``python3-pip`` instead.
+If you're on Python 2 use ``python-dev`` instead.
macOS
=====
Install `Xcode <https://developer.apple.com/downloads/?name=Xcode>`__ then run::
- pip install psutil
+ pip3 install psutil
Windows
=======
Open a cmd.exe shell and run::
- python -m pip install psutil
+ python3 -m pip install psutil
This assumes "python" is in your PATH. If not, specify the full python.exe
path.
@@ -76,16 +76,16 @@ Once installed run `vcvars64.bat`
(see `here <http://stackoverflow.com/questions/11072521/>`__).
Once VS is setup open a cmd.exe shell, cd into psutil directory and run::
- python setup.py build
- python setup.py install
+ python3 setup.py build
+ python3 setup.py install
FreeBSD
=======
::
- pkg install python gcc
- python -m pip install psutil
+ pkg install python3 gcc
+ python -m pip3 install psutil
OpenBSD
@@ -94,35 +94,32 @@ OpenBSD
::
export PKG_PATH="http://ftp.openbsd.org/pub/OpenBSD/`uname -r`/packages/`arch -s`/"
- pkg_add -v python gcc
- python -m pip install psutil
+ pkg_add -v python3 gcc
+ python3 -m pip install psutil
NetBSD
======
::
+
export PKG_PATH="ftp.netbsd.org/pub/pkgsrc/packages/NetBSD/`uname -m`/`uname -r`/All"
pkg_add -v pkgin
- pkgin install python gcc
- python -m pip install psutil
+ pkgin install python3 gcc
+ python3 -m pip install psutil
Solaris
=======
-If ``cc`` compiler is not installed create a symlink to ``gcc``:
-
-::
+If ``cc`` compiler is not installed create a symlink to ``gcc``::
sudo ln -s /usr/bin/gcc /usr/local/bin/cc
-Install:
-
-::
+Install::
pkg install gcc
- python -m pip install psutil
+ python3 -m pip install psutil
Install from sources
@@ -132,11 +129,10 @@ Install from sources
git clone https://github.com/giampaolo/psutil.git
cd psutil
- python setup.py install
+ python3 setup.py install
Dev Guide
=========
-If you wan to hacking or contribute on psutil continue reading the
-`dev guide <https://github.com/giampaolo/psutil/blob/master/docs/DEVGUIDE.rst>`__
+See: `dev guide <https://github.com/giampaolo/psutil/blob/master/docs/DEVGUIDE.rst>`__.