summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2019-03-01 16:24:48 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2019-03-01 16:24:48 +0100
commit784fac235b6305065eda1ff47a5df86c16eb866c (patch)
treeea474a8f28441bbd96fd21cef64a80729089f074 /INSTALL.rst
parentd01a9eaa35a8aadf6c519839e987a49d8be2d891 (diff)
downloadpsutil-784fac235b6305065eda1ff47a5df86c16eb866c.tar.gz
update doc
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst27
1 files changed, 16 insertions, 11 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index be9f94fa..567758c9 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -20,18 +20,15 @@ Permission issues (UNIX)
========================
The commands below assume you're running as root.
-If you're not or you bump into permission errors you can either:
-
-* install psutil for your user only::
+If you're not or you bump into permission errors you can either install psutil
+for your user only::
pip install --user psutil
-
-* prepend ``sudo``, e.g.::
+...or prepend ``sudo``, e.g.::
sudo pip install psutil
-
Linux
=====
@@ -50,9 +47,7 @@ If you're on Python 3 use ``python3-dev`` and ``python3-pip`` instead.
macOS
=====
-* install Xcode: https://developer.apple.com/downloads/?name=Xcode
-
-* run::
+Install `Xcode <https://developer.apple.com/downloads/?name=Xcode>`__ then run::
pip install psutil
@@ -88,17 +83,21 @@ FreeBSD
=======
::
+
pkg install python gcc
python -m pip install psutil
+
OpenBSD
=======
::
+
export PKG_PATH="http://ftp.openbsd.org/pub/OpenBSD/`uname -r`/packages/`arch -s`/"
pkg_add -v python gcc
python -m pip install psutil
+
NetBSD
======
@@ -108,30 +107,36 @@ NetBSD
pkgin install python gcc
python -m pip install psutil
+
Solaris
=======
If ``cc`` compiler is not installed create a symlink to ``gcc``:
::
+
sudo ln -s /usr/bin/gcc /usr/local/bin/cc
Install:
::
+
pkg install gcc
python -m pip install psutil
+
Install from sources
====================
::
+
git clone https://github.com/giampaolo/psutil.git
cd psutil
python setup.py install
+
Dev Guide
=========
-If you plan on hacking on psutil you may want to take a look at the dev guide:
-https://github.com/giampaolo/psutil/blob/master/docs/DEVGUIDE.rst
+If you wan to hacking or contribute on psutil continue reading the
+`dev guide <https://github.com/giampaolo/psutil/blob/master/docs/DEVGUIDE.rst>`__