summaryrefslogtreecommitdiff
path: root/INSTALL.rst
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-02-06 19:13:34 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2015-02-06 19:13:34 +0100
commitc8a77563eec70404cc6991da6686bc8f3d9358af (patch)
treee092e20ea9cb439090743e0978e48d85d60e245e /INSTALL.rst
parent0ae075fdef34a8a3706bae5c6e5134e8fbdc3cc7 (diff)
downloadpsutil-c8a77563eec70404cc6991da6686bc8f3d9358af.tar.gz
point to INSTALL.rst in the doc and README.rst
Diffstat (limited to 'INSTALL.rst')
-rw-r--r--INSTALL.rst30
1 files changed, 15 insertions, 15 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index bb30a06b..72072065 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -4,12 +4,12 @@ Installing using pip on UNIX
The easiest way to install psutil on UNIX is by using pip (but first you might
need to install python header files; see later).
-First install pip:
+First install pip::
$ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
-...then run:
+...then run::
$ pip install psutil
@@ -29,19 +29,19 @@ Compiling on Windows using mingw32
==================================
First install mingw (http://www.mingw.org/) then add mingw "bin" folder to
-environment PATH (NOTE: this assumes MinGW is installed in C:\MinGW):
+environment PATH (NOTE: this assumes MinGW is installed in C:\MinGW)::
SET PATH=C:\MinGW\bin;%PATH%
-You can then compile psutil by running:
+You can then compile psutil by running::
setup.py build -c mingw32
-To compile and install:
+To compile and install::
setup.py build -c mingw32 install
-You can also use make.bat which automatically sets the env variable for you:
+You can also use make.bat which automatically sets the env variable for you::
make.bat build
@@ -60,11 +60,11 @@ Visual Studio used to compile your installation of Python which is::
Python 2.7: VS 2008
Python 3.3+: VS 2010
-...then run:
+...then run::
setup.py build
-...or:
+...or::
make.bat build
@@ -82,15 +82,15 @@ Installing on Linux
===================
gcc is required and so the python headers. They can easily be installed by
-using the distro package manager. For example, on Debian amd Ubuntu:
+using the distro package manager. For example, on Debian amd Ubuntu::
$ sudo apt-get install gcc python-dev
-...on Redhat and CentOS:
+...on Redhat and CentOS::
$ sudo yum install gcc python-devel
-Once done, you can build/install psutil with:
+Once done, you can build/install psutil with::
$ python setup.py install
@@ -102,11 +102,11 @@ Installing on OS X
OS X installation from source will require gcc which you can obtain as part of
the 'XcodeTools' installer from Apple. Then you can run the standard distutils
commands.
-To build only:
+To build only::
$ python setup.py build
-To install and build:
+To install and build::
$ python setup.py install
@@ -119,11 +119,11 @@ The same compiler used to install Python must be present on the system in order
to build modules using distutils. Assuming it is installed, you can build using
the standard distutils commands.
-Build only:
+Build only::
$ python setup.py build
-Install and build:
+Install and build::
$ python setup.py install