summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2019-06-29 15:39:23 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2019-06-29 15:39:23 +0200
commit03a02fe6af19bb875a07a052656544a9b133e10b (patch)
tree424d156ca78be9cdb6f4131a329beed042071403 /Makefile
parenta4fcd0916aa079fd66880d89dff489a7d4a5b7fb (diff)
downloadpsutil-03a02fe6af19bb875a07a052656544a9b133e10b.tar.gz
add script to help fix flake8 issues
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index a3763848..3f8f4c2d 100644
--- a/Makefile
+++ b/Makefile
@@ -174,6 +174,9 @@ test-coverage: ## Run test coverage.
flake8: ## flake8 linter.
@git ls-files | grep \\.py$ | xargs $(PYTHON) -m flake8
+fix-flake8: ## Attempt to automaticall fix some flake8 issues.
+ @git ls-files | grep \\.py$ | xargs $(PYTHON) -m flake8 --exit-zero | $(PYTHON) scripts/internal/fix_flake8.py
+
# ===================================================================
# GIT
# ===================================================================