summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-05-20 22:13:49 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-05-20 22:13:49 +0200
commit1fa6e3c1f81a312c8f652e8ef446dbdd3f72c36c (patch)
treef296ffd56164aba839f8782c0095f8d9b6584f59 /Makefile
parent992dfe4620bbda3316b54c53b63236f3159aa5f9 (diff)
downloadpsutil-1fa6e3c1f81a312c8f652e8ef446dbdd3f72c36c.tar.gz
remove tidelift.py script
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index dc18e62e..d544dd1c 100644
--- a/Makefile
+++ b/Makefile
@@ -270,9 +270,6 @@ check-sdist: ## Create source distribution and checks its sanity (MANIFEST)
build/venv/bin/python -m pip install -v --isolated --quiet dist/*.tar.gz
build/venv/bin/python -c "import os; os.chdir('build/venv'); import psutil"
-tidelift-relnotes: ## upload release notes from HISTORY
- $(PYTHON) scripts/internal/tidelift.py
-
pre-release: ## Check if we're ready to produce a new release.
${MAKE} check-sdist
${MAKE} install
@@ -296,7 +293,6 @@ release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
$(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff --quiet && git diff --cached --quiet', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else 0 ;"
$(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PyPI
${MAKE} git-tag-release
- ${MAKE} tidelift-relnotes
check-manifest: ## Inspect MANIFEST.in file.
$(PYTHON) -m check_manifest -v $(ARGS)