summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-11-11 18:13:58 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2022-11-11 18:13:58 +0100
commit3290ead1b20633b5f77f114bd9b33ad85e28f7fc (patch)
tree42770d65e707695288694ecc372755ecf6df5798 /Makefile
parentf65346fd57df6a23b5ab3ed661d425efe37cbd2a (diff)
downloadpsutil-3290ead1b20633b5f77f114bd9b33ad85e28f7fc.tar.gz
improve and rename print_wheels.py script
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 930325dd..5088cb72 100644
--- a/Makefile
+++ b/Makefile
@@ -234,14 +234,14 @@ install-git-hooks: ## Install GIT pre-commit hook.
download-wheels-github: ## Download latest wheels hosted on github.
$(PYTHON) scripts/internal/download_wheels_github.py --tokenfile=~/.github.token
- ${MAKE} print-wheels
+ ${MAKE} print-dist
download-wheels-appveyor: ## Download latest wheels hosted on appveyor.
$(PYTHON) scripts/internal/download_wheels_appveyor.py
- ${MAKE} print-wheels
+ ${MAKE} print-dist
-print-wheels: ## Print downloaded wheels
- $(PYTHON) scripts/internal/print_wheels.py
+print-dist: ## Print downloaded wheels / tar.gs
+ $(PYTHON) scripts/internal/print_dist.py
# ===================================================================
# Distribution
@@ -275,7 +275,7 @@ pre-release: ## Check if we're ready to produce a new release.
${MAKE} download-wheels-github
${MAKE} download-wheels-appveyor
${MAKE} print-hashes
- ${MAKE} print-wheels
+ ${MAKE} print-dist
$(PYTHON) -m twine check --strict dist/*
$(PYTHON) -c \
"from psutil import __version__ as ver; \