summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-04-30 14:45:08 -0700
committerGitHub <noreply@github.com>2020-04-30 23:45:08 +0200
commit3480e1b05f3e98744a1b6aa6fe286caac86e6bbd (patch)
tree4c3dc33e7102e60b3a49555a3c91c4a7493d1556 /Makefile
parent5f56983c2195ff6c20c8066749fa8b28d47dbd2e (diff)
downloadpsutil-3480e1b05f3e98744a1b6aa6fe286caac86e6bbd.tar.gz
Per-test file cleanup and new PsutilTestCase (#1743)
Test files/dirs are now removed after each test. when invoked via self.get_testfn(). Until now test files were stored in a global variable and were removed at process exit, via atexit.register(), but this didn't work with parallel tests because the fork()ed workers use os._exit(0), preventing cleanup functions to run. All test classes now inherit from PsutilTestCase class, which provides the most important methods requiring an automatic cleanup (get_test_subprocess() and others).
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f6e8ba70..86727ca7 100644
--- a/Makefile
+++ b/Makefile
@@ -59,7 +59,7 @@ clean: ## Remove all build files.
rm -rf \
*.core \
*.egg-info \
- *\$testfn* \
+ *\@psutil-* \
.coverage \
.failed-tests.txt \
.tox \