summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-05-25 14:20:31 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-05-25 14:20:31 +0200
commit379598312f60bf414afa8bf549f7f26af9e578ea (patch)
tree358329d1c4c848a99d980d64f2b27b2a7401876b /Makefile
parentc14744db097b1955f2b668dc753b2d2439db0bdf (diff)
downloadpsutil-379598312f60bf414afa8bf549f7f26af9e578ea.tar.gz
introduce flake8-bugbear code checker
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index d544dd1c..838d7b47 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,7 @@ DEPS = \
coverage \
flake8 \
flake8-print \
+ flake8-bugbear \
isort \
pyperf \
pypinfo \
@@ -188,19 +189,19 @@ test-coverage: ## Run test coverage.
# Linters
# ===================================================================
-check-flake8: ## Run flake8 linter.
+flake8: ## Run flake8 linter.
@git ls-files '*.py' | xargs $(PYTHON) -m flake8 --config=.flake8
-check-imports: ## Run isort linter.
+isort: ## Run isort linter.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg --check-only
-check-c-code: ## Run C linter.
+c-linter: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py
-check-all: ## Run all linters
- ${MAKE} check-flake8
- ${MAKE} check-imports
- ${MAKE} check-c-code
+lint-all: ## Run all linters
+ ${MAKE} flake8
+ ${MAKE} isort
+ ${MAKE} c-linter
# ===================================================================
# Fixers