summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-10-12 09:20:50 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-10-12 09:20:50 +0200
commit38f43df717386e767de0b1e044bb17510b0b1a6c (patch)
tree6ae447ded9ce02ee53e8193d5a71683a909f9959 /Makefile
parent1d8399a9a0822e0f2216409f316aa1f2e966efc6 (diff)
downloadpsutil-38f43df717386e767de0b1e044bb17510b0b1a6c.tar.gz
pre releaserelease-5.4.0
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 1ed62c39..8c9e8e01 100644
--- a/Makefile
+++ b/Makefile
@@ -237,9 +237,6 @@ win-upload-exes:
# All the necessary steps before making a release.
pre-release:
- ${MAKE} generate-manifest
- git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
- @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
${MAKE} install
@PYTHONWARNINGS=all $(PYTHON) -c \
"from psutil import __version__ as ver; \
@@ -248,6 +245,9 @@ pre-release:
assert ver in doc, '%r not in docs/index.rst' % ver; \
assert ver in history, '%r not in HISTORY.rst' % ver; \
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
+ ${MAKE} generate-manifest
+ git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
+ @PYTHONWARNINGS=all $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff-index HEAD --', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else sys.exit(0);"
${MAKE} win-download-exes
${MAKE} sdist