summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-05-18 00:25:08 +0200
committerGitHub <noreply@github.com>2020-05-18 00:25:08 +0200
commit42bc319fd087ede6ab91b149608bbfc030b64890 (patch)
tree40f1269880df7267940c7b2728685d53b53cc536 /Makefile
parent135628639bd6d73b5e88aefe300acd13a04a858d (diff)
downloadpsutil-42bc319fd087ede6ab91b149608bbfc030b64890.tar.gz
Wheels2 (#1761)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 29afe2de..e91dfd81 100644
--- a/Makefile
+++ b/Makefile
@@ -222,8 +222,11 @@ sdist: ## Create tar.gz source distribution.
wheel: ## Generate wheel.
$(PYTHON) setup.py bdist_wheel
-win-download-wheels: ## Download wheels hosted on appveyor.
- $(TEST_PREFIX) $(PYTHON) scripts/internal/win_download_wheels.py --user giampaolo --project psutil
+win-download-wheels: ## Download latest wheels hosted on appveyor.
+ $(PYTHON) scripts/internal/win_download_wheels.py --user giampaolo --project psutil
+
+download-wheels: ## Download latest wheels hosted on github.
+ $(PYTHON) scripts/internal/download_wheels.py --user=giampaolo --project=psutil --tokenfile=~/.github.token
upload-src: ## Upload source tarball on https://pypi.org/project/psutil/
${MAKE} sdist