summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-04-06 17:27:22 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-04-06 17:27:22 +0200
commit48a036cb829294ee508bed6428ab927042e5d5fb (patch)
tree6de2ad97766873f8e27b3555bc5453e5f3bc49f5 /Makefile
parent3b52ce5ff9be8dd37fb59109016b655f078fe499 (diff)
downloadpsutil-48a036cb829294ee508bed6428ab927042e5d5fb.tar.gz
use autopep8 to automatically fix (some) flake8 failures; get rid of old handmade script
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 0ab1ea06..16c7bb26 100644
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
argparse \
+ autopep8 \
check-manifest \
concurrencytest \
coverage \
@@ -206,8 +207,8 @@ lint: ## Run all linters
# Fixers
# ===================================================================
-fix-flake8: ## Attempt to automatically fix some Python flake8 issues.
- @git ls-files | grep \\.py$ | xargs $(PYTHON) -m flake8 --exit-zero | $(PYTHON) scripts/internal/fix_flake8.py
+fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
+ @git ls-files | grep \\.py$ | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg