summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-04-16 02:35:41 +0300
committerGitHub <noreply@github.com>2022-04-16 01:35:41 +0200
commit6ab8a54615ddb9c2f6287047686e3f5b063440ba (patch)
treedb91518f41e5e363a7e17b9664e1482cefa45760 /Makefile
parentb135380591a4c9616c9f1d54fbfa93c8f2ee4228 (diff)
downloadpsutil-6ab8a54615ddb9c2f6287047686e3f5b063440ba.tar.gz
Drop Python 2.6 support (#2099)
Signed-off-by: Hugo van Kemenade <hugovk@users.noreply.github.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 7e998042..a3075012 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,6 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
- argparse \
autoflake \
autopep8 \
check-manifest \
@@ -29,8 +28,7 @@ DEPS = \
PY2_DEPS = \
futures \
ipaddress \
- mock \
- unittest2
+ mock
DEPS += `$(PYTHON) -c \
"import sys; print('$(PY2_DEPS)' if sys.version_info[0] == 2 else '')"`
# "python3 setup.py build" can be parallelized on Python >= 3.6.