summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-06-08 00:42:49 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-06-08 00:42:49 +0200
commit8151bbe1ec2057a9c44eaefdd23e4f59788147b0 (patch)
tree704d9db1cb4a0d9fd6dc5cc9cef2ae006a3fcde6 /Makefile
parentddea4072684561fc8fe754a7f2baf0cc6a787c33 (diff)
downloadpsutil-8151bbe1ec2057a9c44eaefdd23e4f59788147b0.tar.gz
update flake8-ers
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 9893b566..4910c13e 100644
--- a/Makefile
+++ b/Makefile
@@ -21,6 +21,7 @@ DEPS = \
flake8-print \
flake8-quotes \
isort \
+ pep8-naming \
pyperf \
pypinfo \
requests \
@@ -211,13 +212,13 @@ lint-all: ## Run all linters
# ===================================================================
fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
- git ls-files | grep \\.py$ | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
- git ls-files | grep \\.py$ | xargs $(PYTHON) -m autoflake --in-place --remove-all-unused-imports --remove-unused-variables
+ @git ls-files '*.py' | xargs $(PYTHON) -m autopep8 --in-place --jobs 0 --global-config=.flake8
+ @git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --remove-all-unused-imports --remove-unused-variables
fix-imports: ## Fix imports with isort.
@git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg
-fix-all:
+fix-all: ## Run all code fixers.
${MAKE} fix-flake8
${MAKE} fix-imports