summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-10-18 21:12:05 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-10-18 21:12:05 +0200
commit8ad2d5ba0cd2665e28e6ab84af11f74a83163471 (patch)
treeb552e27993a5e2b4b1bd10afd97ad6b5cc553caa /Makefile
parent4354b4e77acf9d74558645bf02811639728dca53 (diff)
downloadpsutil-8ad2d5ba0cd2665e28e6ab84af11f74a83163471.tar.gz
move isort and coverage config into pyproject.toml
...since pyproject.toml was introduced in #2040. CC @mayeut Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index caf4c9e9..fb7f89ae 100644
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ TSCRIPT = psutil/tests/runner.py
# Internal.
DEPS = \
- git+https://github.com/PyCQA/autoflake.git \
+ autoflake \
autopep8 \
check-manifest \
concurrencytest \
@@ -195,7 +195,7 @@ flake8: ## Run flake8 linter.
@git ls-files '*.py' | xargs $(PYTHON) -m flake8 --config=.flake8
isort: ## Run isort linter.
- @git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg --check-only
+ @git ls-files '*.py' | xargs $(PYTHON) -m isort --check-only
c-linter: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py
@@ -214,7 +214,7 @@ fix-flake8: ## Run autopep8, fix some Python flake8 / pep8 issues.
@git ls-files '*.py' | xargs $(PYTHON) -m autoflake --in-place --jobs 0 --remove-all-unused-imports --remove-unused-variables --remove-duplicate-keys
fix-imports: ## Fix imports with isort.
- @git ls-files '*.py' | xargs $(PYTHON) -m isort --settings=.isort.cfg
+ @git ls-files '*.py' | xargs $(PYTHON) -m isort
fix-all: ## Run all code fixers.
${MAKE} fix-flake8