summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-11-15 00:27:05 +0100
committerGitHub <noreply@github.com>2020-11-15 00:27:05 +0100
commit8fc5ed1b20c9c9fab75164aae1984698a46974dc (patch)
treed588d132137ce6b47c34ccc8c59117d2e75cb0b4 /Makefile
parentfd69f22ee5ca38ceff32ae3fac15420c5d8fce29 (diff)
downloadpsutil-8fc5ed1b20c9c9fab75164aae1984698a46974dc.tar.gz
Rewrite Linux prlimit() with ctypes (Linux wheels) (#1879)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index d9d344f7..4718976d 100644
--- a/Makefile
+++ b/Makefile
@@ -89,7 +89,7 @@ uninstall: ## Uninstall this package via pip.
$(PYTHON) scripts/internal/purge_installation.py
install-pip: ## Install pip (no-op if already installed).
- $(PYTHON) -c \
+ @$(PYTHON) -c \
"import sys, ssl, os, pkgutil, tempfile, atexit; \
sys.exit(0) if pkgutil.find_loader('pip') else None; \
pyexc = 'from urllib.request import urlopen' if sys.version_info[0] == 3 else 'from urllib2 import urlopen'; \
@@ -103,7 +103,7 @@ install-pip: ## Install pip (no-op if already installed).
f.write(data); \
f.flush(); \
print('downloaded %s' % f.name); \
- code = os.system('%s %s --user' % (sys.executable, f.name)); \
+ code = os.system('%s %s --user --upgrade' % (sys.executable, f.name)); \
f.close(); \
sys.exit(code);"
@@ -214,14 +214,10 @@ install-git-hooks: ## Install GIT pre-commit hook.
download-wheels-appveyor: ## Download latest wheels hosted on appveyor.
$(PYTHON) scripts/internal/download_wheels_appveyor.py --user giampaolo --project psutil
+ ${MAKE} print-wheels
download-wheels-github: ## Download latest wheels hosted on github.
$(PYTHON) scripts/internal/download_wheels_github.py --user=giampaolo --project=psutil --tokenfile=~/.github.token
-
-download-wheels: ## Download wheels from github and appveyor
- rm -rf dist
- ${MAKE} download-wheels-appveyor
- # ${MAKE} download-wheels-github
${MAKE} print-wheels
print-wheels: ## Print downloaded wheels
@@ -265,9 +261,10 @@ pre-release: ## Check if we're ready to produce a new release.
${MAKE} install
${MAKE} generate-manifest
git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
- ${MAKE} download-wheels
+ ${MAKE} download-wheels-github
${MAKE} sdist
$(PYTHON) -m twine check dist/*
+ ${MAKE} md5-dist
$(PYTHON) -c \
"from psutil import __version__ as ver; \
doc = open('docs/index.rst').read(); \
@@ -275,10 +272,9 @@ pre-release: ## Check if we're ready to produce a new release.
assert ver in doc, '%r not in docs/index.rst' % ver; \
assert ver in history, '%r not in HISTORY.rst' % ver; \
assert 'XXXX' not in history, 'XXXX in HISTORY.rst';"
- $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff --quiet && git diff --cached --quiet', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else 0 ;"
release: ## Create a release (down/uploads tar.gz, wheels, git tag release).
- ${MAKE} pre-release
+ $(PYTHON) -c "import subprocess, sys; out = subprocess.check_output('git diff --quiet && git diff --cached --quiet', shell=True).strip(); sys.exit('there are uncommitted changes:\n%s' % out) if out else 0 ;"
$(PYTHON) -m twine upload dist/* # upload tar.gz and Windows wheels on PyPI
${MAKE} git-tag-release
${MAKE} tidelift-relnotes
@@ -310,6 +306,9 @@ print-api-speed: ## Benchmark all API calls
print-downloads: ## Print PYPI download statistics
$(PYTHON) scripts/internal/print_downloads.py
+print-hashes: ## Prints hashes of files in dist/ directory
+ $(PYTHON) scripts/internal/print_hashes.py dist/
+
# ===================================================================
# Misc
# ===================================================================