summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2022-07-07 23:19:53 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2022-07-07 23:19:53 +0200
commita3e569a7adadba6988d9b26692baef91e9d7e959 (patch)
tree206ae6d0f1d284ca5d2e8b25ee75ccc17ab1fb48 /Makefile
parentbe85beb5227c3288a44711abeda140f10ed6c5f4 (diff)
downloadpsutil-a3e569a7adadba6988d9b26692baef91e9d7e959.tar.gz
remove 'import setuptools' from 'make install' as it's unnecessary and slow
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1234fc6a..0d1ef958 100644
--- a/Makefile
+++ b/Makefile
@@ -83,8 +83,6 @@ build: ## Compile (in parallel) without installing.
PYTHONWARNINGS=all $(PYTHON) setup.py build_ext -i $(BUILD_OPTS)
install: ## Install this package as current user in "edit" mode.
- # make sure setuptools is installed (needed for 'develop' / edit mode)
- $(PYTHON) -c "import setuptools"
${MAKE} build
PYTHONWARNINGS=all $(PYTHON) setup.py develop $(INSTALL_OPTS)
$(PYTHON) -c "import psutil" # make sure it actually worked