summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2023-03-18 13:44:21 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2023-03-18 13:44:21 +0100
commitfb0d5d3325efeb56dd0cf48c0f0d2379baca20d5 (patch)
tree3e48f8d366739c45d293f002144566d73b2f0ed8 /Makefile
parentdc4f7f50e859144c1092a6c225949c536072ea64 (diff)
downloadpsutil-fb0d5d3325efeb56dd0cf48c0f0d2379baca20d5.tar.gz
Makefile: set PSUTIL_SCRIPTS_DIR for 'test' target (re. to #2211)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 1816bd96..f5472bf4 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,7 @@ BUILD_OPTS = `$(PYTHON) -c \
# In not in a virtualenv, add --user options for install commands.
INSTALL_OPTS = `$(PYTHON) -c \
"import sys; print('' if hasattr(sys, 'real_prefix') or hasattr(sys, 'base_prefix') and sys.base_prefix != sys.prefix else '--user')"`
-TEST_PREFIX = PYTHONWARNINGS=always PSUTIL_DEBUG=1
+TEST_PREFIX = PSUTIL_SCRIPTS_DIR=`pwd`/scripts PYTHONWARNINGS=always PSUTIL_DEBUG=1
# if make is invoked with no arg, default to `make help`
.DEFAULT_GOAL := help