summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2018-04-13 04:52:55 -0400
committerGitHub <noreply@github.com>2018-04-13 04:52:55 -0400
commit34e98b6e2a5739f9e633436e8cd61f3246c1091e (patch)
tree21473ba822b34ae5d030fe7ba021127e130e52bc /appveyor.yml
parent1e63ab355d592fefd77c819fb642fe6d7963f295 (diff)
downloadpsutil-34e98b6e2a5739f9e633436e8cd61f3246c1091e.tar.gz
771 Windows CPU count (#1257)
* use GetLogicalProcessorInformation() to get logical cpu_count() * return None if cpu_count() is undetermined + add mock test * style * factor out logical CPU num fun * remove unused code * psutil_get_num_cpus(): provide an option to fail on err * add comments * reuse get_num_cpus() function * error out if get_num_cpus() fail * use GetLogicalProcessorInformationEx to get phys CPU num * on win vista/xp just return None for phys CPU count * rename vars * fix C compiler warnings + remove mingw workarounds * return None if phys cpu count cant' be determined; update HISTORY * update HISTORY * update doc * add WMI tests * refactor tests * print debug msg for cpu phys returning None on win < 7 * try to fix win test * appveyor debug * fix typo * adjust appveyor 64 bit versions * debug msg * fix for loop * re-enable python versions * (maybe) finally fix GetLogicalProcessorInformationEx return len
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml18
1 files changed, 4 insertions, 14 deletions
diff --git a/appveyor.yml b/appveyor.yml
index f39053ad..436faadb 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -45,20 +45,13 @@ environment:
- PYTHON: "C:\\Python35-x64"
PYTHON_VERSION: "3.5.x"
PYTHON_ARCH: "64"
- ARCH: x86_64
- VS_VER: "2015"
- INSTANCENAME: "SQL2012SP1"
- PYTHON: "C:\\Python36-x64"
PYTHON_VERSION: "3.6.x"
PYTHON_ARCH: "64"
- ARCH: x86_64
- VS_VER: "2015"
- INSTANCENAME: "SQL2012SP1"
# Also build on a Python version not pre-installed by Appveyor.
# See: https://github.com/ogrisel/python-appveyor-demo/issues/10
-
# - PYTHON: "C:\\Python266"
# PYTHON_VERSION: "2.6.6"
# PYTHON_ARCH: "32"
@@ -71,20 +64,17 @@ install:
# - ps: (new-object net.webclient).DownloadFile('https://raw.github.com/pypa/pip/master/contrib/get-pip.py', 'C:/get-pip.py')
- "%WITH_COMPILER% %PYTHON%/python.exe -m pip --version"
- "%WITH_COMPILER% %PYTHON%/python.exe -m pip install --upgrade --user setuptools pip"
- - "%WITH_COMPILER% %PYTHON%/python.exe -m pip freeze"
- - "%WITH_COMPILER% %PYTHON%/python.exe setup.py build"
- - "%WITH_COMPILER% %PYTHON%/python.exe setup.py build build_ext -i"
- - "%WITH_COMPILER% %PYTHON%/python.exe setup.py develop"
- "%WITH_COMPILER% %PYTHON%/python.exe scripts/internal/winmake.py setup-dev-env"
+ - "%WITH_COMPILER% %PYTHON%/python.exe -m pip freeze"
+ - "%WITH_COMPILER% %PYTHON%/python.exe scripts/internal/winmake.py install"
build: off
test_script:
- - "%WITH_COMPILER% %PYTHON%/python -V"
- - "set PYTHONWARNINGS=all && set PSUTIL_TESTING=1 && set PSUTIL_DEBUG=1 && %WITH_COMPILER% %PYTHON%/python psutil/tests/__main__.py"
+ - "%WITH_COMPILER% %PYTHON%/python.exe scripts/internal/winmake.py test"
after_test:
- - "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
+ - "%WITH_COMPILER% %PYTHON%/python.exe scripts/internal/winmake.py wheel"
artifacts:
- path: dist\*