summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-05-14 21:59:17 -0400
committerGiampaolo Rodola <g.rodola@gmail.com>2016-05-14 21:59:17 -0400
commit9778a76254328ee6cac1268b255fea30b39a4173 (patch)
tree49acfdad0d29e6a0f511316546ed16b86bd72b03 /appveyor.yml
parent3ff8fce69f6635efb09b159cf87c7afffd49c598 (diff)
downloadpsutil-9778a76254328ee6cac1268b255fea30b39a4173.tar.gz
try to upgrade pip
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml53
1 files changed, 27 insertions, 26 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 0839898e..6a6edf6c 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -18,38 +18,38 @@ environment:
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "32"
- - PYTHON: "C:\\Python33"
- PYTHON_VERSION: "3.3.x"
- PYTHON_ARCH: "32"
+ # - PYTHON: "C:\\Python33"
+ # PYTHON_VERSION: "3.3.x"
+ # PYTHON_ARCH: "32"
- - PYTHON: "C:\\Python34"
- PYTHON_VERSION: "3.4.x"
- PYTHON_ARCH: "32"
+ # - PYTHON: "C:\\Python34"
+ # PYTHON_VERSION: "3.4.x"
+ # PYTHON_ARCH: "32"
- - PYTHON: "C:\\Python35"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "32"
+ # - PYTHON: "C:\\Python35"
+ # PYTHON_VERSION: "3.5.x"
+ # PYTHON_ARCH: "32"
- # 64 bits
+ # # 64 bits
- - PYTHON: "C:\\Python27-x64"
- PYTHON_VERSION: "2.7.x"
- PYTHON_ARCH: "64"
+ # - PYTHON: "C:\\Python27-x64"
+ # PYTHON_VERSION: "2.7.x"
+ # PYTHON_ARCH: "64"
- - PYTHON: "C:\\Python33-x64"
- PYTHON_VERSION: "3.3.x"
- PYTHON_ARCH: "64"
+ # - PYTHON: "C:\\Python33-x64"
+ # PYTHON_VERSION: "3.3.x"
+ # PYTHON_ARCH: "64"
- - PYTHON: "C:\\Python34-x64"
- PYTHON_VERSION: "3.4.x"
- PYTHON_ARCH: "64"
+ # - PYTHON: "C:\\Python34-x64"
+ # PYTHON_VERSION: "3.4.x"
+ # PYTHON_ARCH: "64"
- - PYTHON: "C:\\Python35-x64"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "64"
- ARCH: x86_64
- VS_VER: "2015"
- INSTANCENAME: "SQL2012SP1"
+ # - PYTHON: "C:\\Python35-x64"
+ # PYTHON_VERSION: "3.5.x"
+ # PYTHON_ARCH: "64"
+ # ARCH: x86_64
+ # VS_VER: "2015"
+ # INSTANCENAME: "SQL2012SP1"
# XXX - not sure how to fix this:
# https://ci.appveyor.com/project/giampaolo/psutil/build/354/job/uqf3rms55mrv90ju
@@ -70,7 +70,8 @@ init:
install:
- "powershell .ci\\appveyor\\install.ps1"
# - ps: (new-object net.webclient).DownloadFile('https://raw.github.com/pypa/pip/master/contrib/get-pip.py', 'C:/get-pip.py')
- - "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe install unittest2 ipaddress pypiwin32 wmi wheel setuptools --upgrade"
+ - "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe --version"
+ - "%WITH_COMPILER% %PYTHON%/Scripts/pip.exe install --user --upgrade unittest2 ipaddress pypiwin32 wmi wheel setuptools pip"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py build build_ext -i"
- "%WITH_COMPILER% %PYTHON%/python.exe setup.py develop"