summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-10-31 15:37:31 +0100
committerGitHub <noreply@github.com>2020-10-31 15:37:31 +0100
commit9aba2efe6cee0a343002d0453674aca68a7b7aec (patch)
tree2b0b95c7711bcba4f3911ea44b9d9846a18380d4 /appveyor.yml
parent40abe5c0aa3e258161284b58cedcee1e11a66e75 (diff)
downloadpsutil-9aba2efe6cee0a343002d0453674aca68a7b7aec.tar.gz
Fix py 3.9 [WinError 998] Invalid access to memory location (#1866)
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml19
1 files changed, 11 insertions, 8 deletions
diff --git a/appveyor.yml b/appveyor.yml
index e0912a1e..ff9d35b9 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -15,10 +15,6 @@ environment:
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "32"
- - PYTHON: "C:\\Python35"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "32"
-
- PYTHON: "C:\\Python36"
PYTHON_VERSION: "3.6.x"
PYTHON_ARCH: "32"
@@ -31,16 +27,17 @@ environment:
PYTHON_VERSION: "3.8.x"
PYTHON_ARCH: "32"
+ - PYTHON: "C:\\Python39"
+ PYTHON_VERSION: "3.9.x"
+ APPVEYOR_BUILD_WORKER_IMAGE: Visual Studio 2019
+ PYTHON_ARCH: "32"
+
# 64 bits
- PYTHON: "C:\\Python27-x64"
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "64"
- - PYTHON: "C:\\Python35-x64"
- PYTHON_VERSION: "3.5.x"
- PYTHON_ARCH: "64"
-
- PYTHON: "C:\\Python36-x64"
PYTHON_VERSION: "3.6.x"
PYTHON_ARCH: "64"
@@ -53,6 +50,11 @@ environment:
PYTHON_VERSION: "3.8.x"
PYTHON_ARCH: "64"
+ - PYTHON: "C:\\Python39-x64"
+ PYTHON_VERSION: "3.9.x"
+ APPVEYOR_BUILD_WORKER_IMAGE: Visual Studio 2019
+ PYTHON_ARCH: "64"
+
init:
- "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
@@ -103,3 +105,4 @@ only_commits:
- psutil/tests/*
- scripts/*
- setup.py
+