summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-07-11 14:11:17 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2015-07-11 14:11:17 +0200
commita28f7ab6f545e279a02070070296cc5ba3a3debc (patch)
treeacd09be318c889532f02fa670143339cfd2e0ac0 /appveyor.yml
parent7d5f098abad774097ef79e4db1a2e87c4a234c08 (diff)
downloadpsutil-a28f7ab6f545e279a02070070296cc5ba3a3debc.tar.gz
try appveyor windows test integrtion service
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml65
1 files changed, 65 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
new file mode 100644
index 00000000..80f037f1
--- /dev/null
+++ b/appveyor.yml
@@ -0,0 +1,65 @@
+environment:
+
+ global:
+ # SDK v7.0 MSVC Express 2008's SetEnv.cmd script will fail if the
+ # /E:ON and /V:ON options are not enabled in the batch script intepreter
+ # See: http://stackoverflow.com/a/13751649/163740
+ WITH_COMPILER: "cmd /E:ON /V:ON /C .\\appveyor\\run_with_compiler.cmd"
+
+ matrix:
+ # Pre-installed Python versions, which Appveyor may upgrade to
+ # a later point release.
+
+ - PYTHON: "C:\\Python27"
+ PYTHON_VERSION: "2.7.x" # currently 2.7.9
+ PYTHON_ARCH: "32"
+
+ # - PYTHON: "C:\\Python33"
+ # PYTHON_VERSION: "3.3.x" # currently 3.3.5
+ # PYTHON_ARCH: "32"
+
+ # - PYTHON: "C:\\Python34"
+ # PYTHON_VERSION: "3.4.x" # currently 3.4.3
+ # PYTHON_ARCH: "32"
+
+ # - PYTHON: "C:\\Python27-x64"
+ # PYTHON_VERSION: "2.7.x" # currently 2.7.9
+ # PYTHON_ARCH: "64"
+ # WINDOWS_SDK_VERSION: "v7.0"
+
+ # - PYTHON: "C:\\Python33-x64"
+ # PYTHON_VERSION: "3.3.x" # currently 3.3.5
+ # PYTHON_ARCH: "64"
+ # WINDOWS_SDK_VERSION: "v7.1"
+
+ # - PYTHON: "C:\\Python34-x64"
+ # PYTHON_VERSION: "3.4.x" # currently 3.4.3
+ # PYTHON_ARCH: "64"
+ # WINDOWS_SDK_VERSION: "v7.1"
+
+ # Also build on a Python version not pre-installed by Appveyor.
+ # See: https://github.com/ogrisel/python-appveyor-demo/issues/10
+
+ # - PYTHON: "C:\\Python266"
+ # PYTHON_VERSION: "2.6.6"
+ # PYTHON_ARCH: "32"
+
+init:
+ - "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
+
+install:
+ - "powershell appveyor\\install.ps1"
+
+build: off
+
+test_script:
+ - "%WITH_COMPILER% %PYTHON%/python setup.py test\test_psutil.py"
+
+# after_test:
+# - "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
+
+artifacts:
+ - path: dist\*
+
+#on_success:
+# - TODO: upload the content of dist/*.whl to a public wheelhouse