summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-03-09 19:51:10 -0800
committerGiampaolo Rodola <g.rodola@gmail.com>2018-03-09 19:51:10 -0800
commitb578d2febfd35f80fcfa1ce1bdf18d44d21b1581 (patch)
tree5341acf84032ee89457b973d3c0fd24f332c4db4 /appveyor.yml
parentb409472c271c0f803cfa8ecc83033e508f2ae429 (diff)
downloadpsutil-b578d2febfd35f80fcfa1ce1bdf18d44d21b1581.tar.gz
Move tests out of package to top level directory (#1232)
Cleanly separates tests from the package itself. Prevents the tests being installed to site-packages. Tests are still distributed with the source distribution by MANIFEST.in. Avoids installing tests in production environments, leading to less total code in the environment.
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml16
1 files changed, 8 insertions, 8 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 28f5f7f6..2ceb63f7 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -83,7 +83,7 @@ build: off
test_script:
- "%WITH_COMPILER% %PYTHON%/python -V"
- - "set PYTHONWARNINGS=all && set PSUTIL_TESTING=1 && set PSUTIL_DEBUG=1 && %WITH_COMPILER% %PYTHON%/python psutil/tests/__main__.py"
+ - "set PYTHONWARNINGS=all && set PSUTIL_TESTING=1 && set PSUTIL_DEBUG=1 && %WITH_COMPILER% %PYTHON%/python tests/__main__.py"
after_test:
- "%WITH_COMPILER% %PYTHON%/python setup.py bdist_wheel"
@@ -112,12 +112,12 @@ only_commits:
psutil/_psutil_windows.*
psutil/_pswindows.py
psutil/arch/windows/*
- psutil/tests/__init__.py
- psutil/tests/__main__.py
- psutil/tests/test_memory_leaks.py
- psutil/tests/test_misc.py
- psutil/tests/test_process.py
- psutil/tests/test_system.py
- psutil/tests/test_windows.py
+ tests/__init__.py
+ tests/__main__.py
+ tests/test_memory_leaks.py
+ tests/test_misc.py
+ tests/test_process.py
+ tests/test_system.py
+ tests/test_windows.py
scripts/*
setup.py