summaryrefslogtreecommitdiff
path: root/docs/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-05-02 15:19:53 -0700
committerGitHub <noreply@github.com>2020-05-03 00:19:53 +0200
commit42368e6a786415d932cb48d0fd006a0c302ab31b (patch)
treebb9ed83939f4742971791fa699282a82844ce66b /docs/Makefile
parent6f2bdc4223789af13156915e930f2fff7d68d46a (diff)
downloadpsutil-42368e6a786415d932cb48d0fd006a0c302ab31b.tar.gz
Process wait() improvements (#1747)
* `Process.wait()` on POSIX now returns an `enum` showing the negative which was used to terminate the process: ```python >>> import psutil >>> p = psutil.Process(9891) >>> p.terminate() >>> p.wait() <Negsignal.SIGTERM: -15> ``` * the return value is cached so that the exit code can be retrieved on then next call, mimicking `subprocess.Popen.wait()` * `Process` object provides more `status` and `exitcode` additional info on `str()` and `repr()`: ``` >>> proc psutil.Process(pid=12739, name='python3', status='terminated', exitcode=<Negsigs.SIGTERM: -15>, started='15:08:20') ``` Extra: * improved `wait()` doc * reverted #1736: `psutil.Popen` uses original `subprocess.Popen.wait` method (safer)
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/docs/Makefile b/docs/Makefile
index cca5435f..860a2b0e 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -15,8 +15,9 @@ ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
# the i18n builder cannot share the environment and doctrees with the others
I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
-DEPS = sphinx
-
+DEPS = \
+ sphinx \
+ sphinx_rtd_theme
.PHONY: help
help: