summaryrefslogtreecommitdiff
path: root/docs/Makefile
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-15 17:46:21 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-15 17:46:21 +0100
commita8c9e878d5b43cbb729187ae6e1304eebd09b8dc (patch)
tree578fcbc89480db76a0828de2d9d2d78f273a02f6 /docs/Makefile
parenta826d41cd880d4aea907f68351c4bc1414d2575c (diff)
downloadpsutil-a8c9e878d5b43cbb729187ae6e1304eebd09b8dc.tar.gz
refactor print colors utils
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/docs/Makefile b/docs/Makefile
index c7f4723a..cca5435f 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -15,6 +15,9 @@ ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
# the i18n builder cannot share the environment and doctrees with the others
I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+DEPS = sphinx
+
+
.PHONY: help
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -224,3 +227,7 @@ dummy:
$(SPHINXBUILD) -b dummy $(ALLSPHINXOPTS) $(BUILDDIR)/dummy
@echo
@echo "Build finished. Dummy builder generates no files."
+
+.PHONY: setup-dev-env
+setup-dev-env: ## Install GIT hooks, pip, test deps (also upgrades them).
+ $(PYTHON) -m pip install --user --upgrade --trusted-host files.pythonhosted.org $(DEPS)