summaryrefslogtreecommitdiff
path: root/make.bat
diff options
context:
space:
mode:
authorGiampaolo Rodola' <g.rodola@gmail.com>2014-02-06 18:27:42 +0100
committerGiampaolo Rodola' <g.rodola@gmail.com>2014-02-06 18:27:42 +0100
commit1d02a51c5ed0e5ca506c04da74c9fb1b62b91a65 (patch)
tree83ae511b5ed1322515d9148e3479903cc39f77fc /make.bat
parentc4fdb14bf7a928249ab84c48f84a54b714042709 (diff)
downloadpsutil-1d02a51c5ed0e5ca506c04da74c9fb1b62b91a65.tar.gz
make.bat set HOME env var to locate the .pypirc file and upload exes on PYPI
Diffstat (limited to 'make.bat')
-rw-r--r--make.bat11
1 files changed, 6 insertions, 5 deletions
diff --git a/make.bat b/make.bat
index ca6a819a..0a10bcf2 100644
--- a/make.bat
+++ b/make.bat
@@ -20,15 +20,20 @@ rem If you compile by using mingw on Python 2.4 and 2.5 you need to patch
rem distutils first: http://stackoverflow.com/questions/13592192
rem ==========================================================================
-
if "%PYTHON%" == "" (
set PYTHON=C:\Python27\python.exe
)
if "%TSCRIPT%" == "" (
set TSCRIPT=test\test_psutil.py
)
+
+rem Needed to compile using Mingw.
set PATH=C:\MinGW\bin;%PATH%
+rem Needed to locate the .pypirc file and upload exes on PYPI.
+set HOME=%USERPROFILE%
+
+rem ==========================================================================
if "%1" == "help" (
:help
@@ -156,10 +161,6 @@ if "%1" == "upload-exes" (
C:\Python33\python.exe setup.py bdist_wininst upload || goto :error
C:\Python34\python.exe setup.py bdist_wininst upload || goto :error
rem 64 bit versions
- rem Python 2.7 + VS 2008 requires vcvars64.bat to be run first:
- rem http://stackoverflow.com/questions/11072521/
- rem Windows SDK and .NET Framework 3.5 SP1 also need to be installed (sigh)
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
C:\Python27-64\python.exe setup.py build bdist_wininst upload || goto :error
C:\Python33-64\python.exe setup.py build bdist_wininst upload || goto :error
C:\Python34-64\python.exe setup.py build bdist_wininst upload || goto :error