summaryrefslogtreecommitdiff
path: root/make.bat
diff options
context:
space:
mode:
authorMark Derbecker <mark.derbecker@seeq.com>2015-08-02 08:15:32 -0700
committerMark Derbecker <mark.derbecker@seeq.com>2015-08-02 08:15:32 -0700
commit9284b544be631b8595a027cebfcf2cfdd2465ef2 (patch)
tree6180315481cc66e1934e871275a270288c989bca /make.bat
parent0925da3f28c5c542e709e3cf09de431e0c7013f2 (diff)
downloadpsutil-9284b544be631b8595a027cebfcf2cfdd2465ef2.tar.gz
improve make.bat's resiliency to Visual Studio install locations
Diffstat (limited to 'make.bat')
-rw-r--r--make.bat8
1 files changed, 5 insertions, 3 deletions
diff --git a/make.bat b/make.bat
index 9c430101..c9b7d55a 100644
--- a/make.bat
+++ b/make.bat
@@ -26,6 +26,8 @@ if "%TSCRIPT%" == "" (
set TSCRIPT=test\test_psutil.py
)
+set VSINSTALLDIR=%VS90COMNTOOLS%..\..
+
set PYTHON26=C:\Python26\python.exe
set PYTHON27=C:\Python27\python.exe
set PYTHON33=C:\Python33\python.exe
@@ -75,7 +77,7 @@ if "%1" == "clean" (
if "%1" == "build" (
:build
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
%PYTHON% setup.py build
if %errorlevel% neq 0 goto :error
rem copies *.pyd files in ./psutil directory in order to allow
@@ -129,7 +131,7 @@ if "%1" == "test-memleaks" (
if "%1" == "build-all" (
:build-all
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
@echo ------------------------------------------------
@echo building exe for %%P
@@ -146,7 +148,7 @@ if "%1" == "build-all" (
if "%1" == "upload-all" (
:upload-exes
- "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
+ "%VSINSTALLDIR%\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
@echo ------------------------------------------------
@echo uploading exe for %%P