summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthieu Darbois <mayeut@users.noreply.github.com>2022-10-18 20:05:17 +0200
committerGitHub <noreply@github.com>2022-10-18 20:05:17 +0200
commit3f81c62ecb37098318fd1f80eebb0bdffc8f097c (patch)
tree0acb3a837cdbb293a7165b2ce66cebbbe74ea46d /pyproject.toml
parent0707c16339c3918f77eeb83cb1d6047cdb2f0e10 (diff)
downloadpsutil-3f81c62ecb37098318fd1f80eebb0bdffc8f097c.tar.gz
fix #2021, fix #1954, provide OSX arm64 bins + add pyproject.toml (#2040)
This commit updates the build workflow to use the latest cibuildwheel as a GitHub Action. cibuildwheel configuration is now in its own file (as there's no `pyproject.toml` yet) Signed-off-by: mayeut <mayeut@users.noreply.github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..47031d26
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,15 @@
+[build-system]
+requires = ["setuptools>=43"]
+build-backend = "setuptools.build_meta"
+
+[tool.cibuildwheel]
+build = ["cp36-*", "cp37-*", "cp38-*", "cp39-*", "cp310-*"]
+skip = ["*-musllinux*"]
+test-extras = "test"
+test-command = [
+ "PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/runner.py",
+ "PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/test_memleaks.py"
+]
+
+[tool.cibuildwheel.macos]
+archs = ["x86_64", "arm64"]