summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthieu Darbois <mayeut@users.noreply.github.com>2022-10-21 01:02:23 +0200
committerGitHub <noreply@github.com>2022-10-21 01:02:23 +0200
commit614e91158ced7a65aabbe7244d52de1cebfc494b (patch)
treee69c295da7ebf41d4f6a11db6378e37916625f1a /pyproject.toml
parent1b09c1b54cb2ae46145de7f710e9b990cd264016 (diff)
downloadpsutil-614e91158ced7a65aabbe7244d52de1cebfc494b.tar.gz
feature: use ABI3 for cp36+ (#2102)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 17 insertions, 3 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 52d4c728..87b84fc6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,12 +38,11 @@ exclude_lines = [
]
[build-system]
-requires = ["setuptools>=43"]
+requires = ["setuptools>=43", "wheel"]
build-backend = "setuptools.build_meta"
[tool.cibuildwheel]
-build = ["cp36-*", "cp37-*", "cp38-*", "cp39-*", "cp310-*"]
-skip = ["*-musllinux*"]
+skip = ["pp*", "*-musllinux*"]
test-extras = "test"
test-command = [
"PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/runner.py",
@@ -52,3 +51,18 @@ test-command = [
[tool.cibuildwheel.macos]
archs = ["x86_64", "arm64"]
+
+[tool.cibuildwheel.windows]
+# psutil tests do not like running from a virtualenv with python>=3.7
+# restrict build & tests to cp36
+# cp36-abi3 wheels will need to be tested outside cibuildwheel for python>=3.7
+build = "cp36-*"
+test-command = [
+ "python {project}/psutil/tests/runner.py",
+ "python {project}/psutil/tests/test_memleaks.py"
+]
+
+[tool.cibuildwheel.windows.environment]
+PYTHONWARNINGS = "always"
+PYTHONUNBUFFERED = "1"
+PSUTIL_DEBUG = "1"