summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatthieu Darbois <mayeut@users.noreply.github.com>2023-03-27 23:37:16 +0200
committerGitHub <noreply@github.com>2023-03-27 23:37:16 +0200
commit64b4318bce1a2ba8dcc0b8f7cbaefeb029c12419 (patch)
tree0dff418c1ae6f1c0abd66c83e2196eb2ae551ad6 /pyproject.toml
parentd07e7f84579b05934bc525614177ec0e1a3b4dd4 (diff)
downloadpsutil-64b4318bce1a2ba8dcc0b8f7cbaefeb029c12419.tar.gz
Win: fix running tests in a virtual environment (#2216)
On windows, starting with python 3.7, virtual environments use a venvlauncher startup process This does not play well when counting spawned processes or when relying on the pid of the spawned process to do some checks e.g. connection check per pid This commit detects this situation and uses the base python executable to spawn processes when required. Signed-off-by: mayeut <mayeut@users.noreply.github.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 0 insertions, 6 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 435cc989..c8cb62af 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -48,9 +48,3 @@ test-command = [
[tool.cibuildwheel.macos]
archs = ["x86_64", "arm64"]
-
-[tool.cibuildwheel.windows]
-# psutil tests do not like running from a virtualenv with python>=3.7
-# restrict build & tests to cp36
-# cp36-abi3 wheels will need to be tested outside cibuildwheel for python>=3.7
-build = "cp36-*"