summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2023-04-01 12:24:59 +0200
committerGitHub <noreply@github.com>2023-04-01 12:24:59 +0200
commit7eadee31db2f038763a3a6f978db1ea76bbc4674 (patch)
tree55d75da147cc3a40b989e18df1126de5167b66cf /pyproject.toml
parent7d55ce4e3d81705264398a15ffaa1896f4e1aefc (diff)
downloadpsutil-7eadee31db2f038763a3a6f978db1ea76bbc4674.tar.gz
Fix pylint warnings / cleanup (#2218)
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c8cb62af..8d68131c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -34,6 +34,44 @@ exclude_lines = [
"raise NotImplementedError",
]
+[tool.pylint.messages_control]
+# Important ones:
+# undefined-all-variable, invalid-envvar-default, reimported, raising-format-tuple, simplifiable-if-expression, useless-object-inheritance
+disable = [
+ "broad-except", # except Exception:
+ "consider-using-dict-comprehension",
+ "consider-using-f-string",
+ "consider-using-set-comprehension",
+ "consider-using-with",
+ "disallowed-name",
+ "fixme",
+ "global-statement",
+ "import-error",
+ "import-outside-toplevel",
+ "inconsistent-return-statements",
+ "invalid-name",
+ "missing-class-docstring",
+ "missing-function-docstring",
+ "no-else-raise",
+ "no-else-return",
+ "protected-access",
+ "raise-missing-from",
+ "redefined-builtin",
+ "super-with-arguments",
+ "too-few-public-methods",
+ "too-many-arguments",
+ "too-many-branches",
+ "too-many-instance-attributes",
+ "too-many-lines",
+ "too-many-locals",
+ "too-many-public-methods",
+ "too-many-return-statements",
+ "too-many-statements",
+ "ungrouped-imports",
+ "unspecified-encoding",
+ "wrong-import-position",
+]
+
[build-system]
requires = ["setuptools>=43", "wheel"]
build-backend = "setuptools.build_meta"